diff mbox series

[bug#42465,v2,06/10] gnu: Add python-lark-parser.

Message ID 20200722120940.13811-6-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42465,v2,01/10] gnu: python-typing-extension: Update to 3.7.4.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 22, 2020, 12:09 p.m. UTC
* gnu/packages/python-xyz.scm (python-lark-parser): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4f959b886c..26673c20c0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12297,6 +12297,25 @@  in Python.  It allows you to declare the libraries your project depends on and
 it will manage (install/update) them for you.")
     (license license:expat)))
 
+(define-public python-lark-parser
+  (package
+    (name "python-lark-parser")
+    (version "0.9.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "lark-parser" version))
+              (sha256
+               (base32
+                "1kd61asrb3h9spgsj4bslfbgp8q4271sw3hblk6f2vbbblv8jxcy"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/lark-parser/lark")
+    (synopsis "A modern parsing library for Python")
+    (description
+     "Lark is a parser built with a focus on ergonomics, performance and resilience.
+Lark can parse all context-free languages.  That means it is capable of parsing almost
+any programming language out there, and to some degree most natural languages too.")
+    (license license:expat)))
+
 (define-public python-libcst
   (package
     (name "python-libcst")