diff mbox series

[bug#42396,2/2] gnu: Add python-mypy.

Message ID 20200716143444.26423-2-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42395,1/2] gnu: Add python-mypy-extensions. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Tanguy LE CARROUR July 16, 2020, 2:34 p.m. UTC
* gnu/packages/python-check.scm (python-mypy): New variable.
---
 gnu/packages/python-check.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Tanguy LE CARROUR July 16, 2020, 2:43 p.m. UTC | #1
Hi Guix!

Sorry, I submitted a patch series, but I failed to open only one bug!
I've just sent a v2 with the 2 patches to #42395, so this on can be closed!

Sorry for the noise!
Tanguy LE CARROUR July 22, 2020, 12:02 p.m. UTC | #2
Replaced by #42465.
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 819ce21e09..ee3e9fe76a 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -471,3 +471,29 @@  Python software under test, when they make an HTTP query.")
     (description "The @code{python-mypy-extensions} module defines experimental
 extensions to the standard 'typing' module that are supported by the mypy typechecker.")
     (license license:expat)))
+
+(define-public python-mypy
+  (package
+    (name "python-mypy")
+    (version "0.782")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "mypy" version))
+        (sha256
+         (base32
+          "030kn709515452n6gy2i1d9fg6fyrkmdz228lfpmbslybsld9xzg"))))
+    (build-system python-build-system)
+    (arguments `(#:tests? #f)); no tests
+    (propagated-inputs
+     `(("python-mypy-extensions" ,python-mypy-extensions)
+       ("python-typing-extensions" ,python-typing-extensions)
+       ("python-typed-ast" ,python-typed-ast)))
+    (home-page "http://www.mypy-lang.org/")
+    (synopsis "Optional static type checker for Python")
+    (description "Mypy is an optional static type checker for Python that aims
+to combine the benefits of dynamic (or 'duck') typing and static typing.  Mypy combines
+the expressive power and convenience of Python with a powerful type system and
+compile-time type checking.  Mypy type checks standard Python programs; run them using
+any Python VM with basically no runtime overhead.")
+    (license license:expat)))