diff mbox series

[bug#42395,1/2] gnu: Add python-mypy-extensions.

Message ID 20200716143444.26423-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42395,1/2] gnu: Add python-mypy-extensions. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Tanguy LE CARROUR July 16, 2020, 2:34 p.m. UTC
* gnu/packages/python-check.scm (python-mypy-extensions): New variable.
---
 gnu/packages/python-check.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Tanguy LE CARROUR July 17, 2020, 8:39 a.m. UTC | #1
Hi Guix!

I've just found out that there's already a bug report with a patch series
for `python-mypy`: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=35193.
But it's more than a year old now, and has never been closed.

So I guess you can close this bug (#42395) and I'll start again where
Jesse left off. This means I have to enable and fix mypy's tests… which will
end up in adding some more new packages.

I'll (properly) open a new bug report when the patch set is ready.

Sorry (again) for the noise!
Marius Bakke July 21, 2020, 9:24 p.m. UTC | #2
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> Hi Guix!
>
> I've just found out that there's already a bug report with a patch series
> for `python-mypy`: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=35193.
> But it's more than a year old now, and has never been closed.
>
> So I guess you can close this bug (#42395) and I'll start again where
> Jesse left off. This means I have to enable and fix mypy's tests… which will
> end up in adding some more new packages.

Awesome, thanks!

Note that you can close bugs yourself by simply appending "-done" to the
bug ID, like I've done in this message.
Tanguy LE CARROUR July 22, 2020, 5:44 a.m. UTC | #3
Le 07/21, Marius Bakke a écrit :
> Note that you can close bugs yourself by simply appending "-done" to the
> bug ID, like I've done in this message.

Sorry, I didn't know! Thanks for closing it!
Does that mean that anybody can close any bug?!
Marius Bakke July 25, 2020, 3:43 p.m. UTC | #4
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> Le 07/21, Marius Bakke a écrit :
>> Note that you can close bugs yourself by simply appending "-done" to the
>> bug ID, like I've done in this message.
>
> Sorry, I didn't know! Thanks for closing it!
> Does that mean that anybody can close any bug?!

Indeed.  Apparently spammers and script kiddies have better things to do
than mess with Debbugs, go figure.  :-)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 200bce6ced..819ce21e09 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bionelang.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -451,3 +452,22 @@  analysing code quality.")
     (description "This package provides a library for replying fake data to
 Python software under test, when they make an HTTP query.")
     (license license:asl2.0)))
+
+(define-public python-mypy-extensions
+  (package
+    (name "python-mypy-extensions")
+    (version "0.4.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "mypy_extensions" version))
+        (sha256
+         (base32
+          "1a04qsk8hd1lqns8w1j7cr0vmvbhg450di5k1i16kqxkbf7q30id"))))
+    (build-system python-build-system)
+    (arguments `(#:tests? #f)); no tests
+    (home-page "https://github.com/python/mypy_extensions")
+    (synopsis "Experimental extensions for MyPy.")
+    (description "The @code{python-mypy-extensions} module defines experimental
+extensions to the standard 'typing' module that are supported by the mypy typechecker.")
+    (license license:expat)))