diff mbox series

[bug#42229,6/9] gnu: jami: Add libnm as input.

Message ID 20200706155030.1938-6-tona_kosmicznego_smiecia@interia.pl
State Accepted
Headers show
Series [bug#42229,1/9] gnu: libring: Fetch from git, update to 20200702-guix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jan Wielkiewicz July 6, 2020, 3:50 p.m. UTC
* gnu/packages/jami.scm (jami)[inputs]: Add libnm.
---
 gnu/packages/jami.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Christopher Baines July 6, 2020, 9:24 p.m. UTC | #1
Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl> writes:

> * gnu/packages/jami.scm (jami)[inputs]: Add libnm.
> ---
>  gnu/packages/jami.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
> index a45b056d51..041955f297 100644
> --- a/gnu/packages/jami.scm
> +++ b/gnu/packages/jami.scm
> @@ -582,6 +582,7 @@ This package provides a library common to all Jami clients.")
>           ("clutter" ,clutter)
>           ("clutter-gtk" ,clutter-gtk)
>           ("libcanberra" ,libcanberra)
> +         ("libnm" ,network-manager)
>           ("webkitgtk" ,webkitgtk)
>           ("sqlite" ,sqlite)))
>        (native-inputs
> @@ -600,7 +601,6 @@ This package provides a library common to all Jami clients.")
>  video and chat communication platform that requires no centralized server and
>  leaves the power of privacy in the hands of the user.  It supports the SIP and
>  IAX protocols, as well as decentralized calling using P2P-DHT.
> -
>  This package provides the Jami client for the GNOME desktop.")
>        (home-page "https://jami.net")
>        (license license:gpl3+))))

I'm guessing that the reasoning behind this change is that it's
something related to the version update.

If so, maybe include this change in the commit that does the version
update, just to keep the related changes together. Otherwise, it would
be good to have some information in this commit about what adding this
input means.
Jan Wielkiewicz July 10, 2020, 6:03 p.m. UTC | #2
Dnia 2020-07-06, o godz. 22:24:28
Christopher Baines <mail@cbaines.net> napisał(a):

> I'm guessing that the reasoning behind this change is that it's
> something related to the version update.
Actually it isn't. I just noticed it is an optional dependency.
I'll add this in a comment.

Quick grep tells:

CMakeLists.txt:PKG_CHECK_MODULES(LIBNM libnm>=1.0) #optional to detect
changes in the network CMakeLists.txt:# configure libnm variable for
config.h file src/mainwindow.cpp:     // monitor the network using
libnm to notify the daemon about connectivity changes



Jan Wielkiewicz
diff mbox series

Patch

diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index a45b056d51..041955f297 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -582,6 +582,7 @@  This package provides a library common to all Jami clients.")
          ("clutter" ,clutter)
          ("clutter-gtk" ,clutter-gtk)
          ("libcanberra" ,libcanberra)
+         ("libnm" ,network-manager)
          ("webkitgtk" ,webkitgtk)
          ("sqlite" ,sqlite)))
       (native-inputs
@@ -600,7 +601,6 @@  This package provides a library common to all Jami clients.")
 video and chat communication platform that requires no centralized server and
 leaves the power of privacy in the hands of the user.  It supports the SIP and
 IAX protocols, as well as decentralized calling using P2P-DHT.
-
 This package provides the Jami client for the GNOME desktop.")
       (home-page "https://jami.net")
       (license license:gpl3+))))