diff mbox series

[bug#42229,5/9] gnu: pjproject-jami: Make sure phases are run in order.

Message ID 20200706155030.1938-5-tona_kosmicznego_smiecia@interia.pl
State Accepted
Headers show
Series [bug#42229,1/9] gnu: libring: Fetch from git, update to 20200702-guix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jan Wielkiewicz July 6, 2020, 3:50 p.m. UTC
* gnu/packages/jami.scm (pjproject-jami)[arguments]:
Add 'apply-patches after 'make-git-checkout-writable.
---
 gnu/packages/jami.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Maxim Cournoyer Aug. 4, 2020, 4:20 a.m. UTC | #1
Hi Jan,

Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl> writes:

> * gnu/packages/jami.scm (pjproject-jami)[arguments]:
> Add 'apply-patches after 'make-git-checkout-writable.
> ---
>  gnu/packages/jami.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
> index a6ce1aaa3f..a45b056d51 100644
> --- a/gnu/packages/jami.scm
> +++ b/gnu/packages/jami.scm
> @@ -153,7 +153,7 @@
>             (lambda _
>               (for-each make-file-writable (find-files "."))
>               #t))
> -         (add-after 'unpack 'apply-patches
> +         (add-after 'make-git-checkout-writable 'apply-patches
>             (lambda* (#:key inputs #:allow-other-keys)
>               (let ((jami-apply-dependency-patches ,jami-apply-dependency-patches))
>                 ;; Comes from

I made some changes to our base pjproject and could simplify the
definition of pjproject-jami to only adding the apply-patches phase.
The phase is sequenced like above.

Let me know if you spot any issue with that work :-).

Maxim
Jan Wielkiewicz Aug. 4, 2020, 1:05 p.m. UTC | #2
Dnia 2020-08-04, o godz. 00:20:35
maxim.cournoyer@gmail.com napisał(a):

> Hi Jan,
> 
> Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl> writes:
> 
> I made some changes to our base pjproject and could simplify the
> definition of pjproject-jami to only adding the apply-patches phase.
> The phase is sequenced like above.
Nice, pjproject was too complicated for me to handle. Does the package
work now? I mean vanilla pjproject, it didn't work without jami patches
and settings before.

> 
> Let me know if you spot any issue with that work :-).
It's Jami, if it works, it means something failed :)
I'll try it.

> Maxim


Jan Wielkiewicz
diff mbox series

Patch

diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index a6ce1aaa3f..a45b056d51 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -153,7 +153,7 @@ 
            (lambda _
              (for-each make-file-writable (find-files "."))
              #t))
-         (add-after 'unpack 'apply-patches
+         (add-after 'make-git-checkout-writable 'apply-patches
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((jami-apply-dependency-patches ,jami-apply-dependency-patches))
                ;; Comes from