diff mbox series

[bug#42107,5/6] gnu: Add r-maxstat.

Message ID 20200628092944.19939-5-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42107,1/6] gnu: Add r-km-ci. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 28, 2020, 9:29 a.m. UTC
* gnu/packages/cran.scm (r-maxstat): New variable.
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3077b1e132..f51e69689b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22430,3 +22430,27 @@  available in package:survival.")
       "Computes exact conditional p-values and quantiles using an
 implementation of the Shift-Algorithm by Streitberg & Roehmel.")
     (license license:gpl2+)))
+
+(define-public r-maxstat
+  (package
+    (name "r-maxstat")
+    (version "0.7-25")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "maxstat" version))
+        (sha256
+          (base32
+            "114z1rwxwvk05ijjhdppzm148n1h192fp0w12ky10zkrhf6kphbg"))))
+    (properties `((upstream-name . "maxstat")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-exactranktests" ,r-exactranktests)
+        ("r-mvtnorm" ,r-mvtnorm)))
+    (home-page
+      "https://cran.r-project.org/web/packages/maxstat/")
+    (synopsis "Maximally Selected Rank Statistics")
+    (description
+      "Maximally selected rank statistics with several p-value
+approximations.")
+    (license license:gpl2+)))