diff mbox series

[bug#42107,1/6] gnu: Add r-km-ci.

Message ID 20200628092944.19939-1-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42107,1/6] gnu: Add r-km-ci. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 28, 2020, 9:29 a.m. UTC
* gnu/packages/cran.scm (r-km-ci): New variable.
---
 gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab5e57c0e2..b054c62550 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22325,3 +22325,28 @@  across a wide array of bioinformatic R packages.")
 and clustering large sequence datasets using fast alignment-free k-mer
 counting and recursive k-means partitioning.")
     (license license:gpl3)))
+
+(define-public r-km-ci
+  (package
+    (name "r-km-ci")
+    (version "0.5-2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "km.ci" version))
+        (sha256
+          (base32
+            "1l6kw8jppaa1802yc5pbfwwgac56nhwc9p076ivylhms4w7cdf8v"))))
+    (properties `((upstream-name . "km.ci")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-survival" ,r-survival)))
+    (home-page
+      "https://cran.r-project.org/web/packages/km.ci/")
+    (synopsis
+      "Confidence intervals for the Kaplan-Meier estimator")
+    (description
+      "Computes various confidence intervals for the Kaplan-Meier
+estimator, namely: Petos CI, Rothman CI, CI's based on Greenwoods
+variance, Thomas and Grunkemeier CI and the simultaneous confidence
+bands by Nair and Hall and Wellner.")
+    (license license:gpl2+)))