diff mbox series

[bug#41816,1/4] gnu: busybox: Make build reproducible.

Message ID 20200611210848.28784-1-dannym@scratchpost.org
State Accepted
Headers show
Series Fix busybox. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

Danny Milosavljevic June 11, 2020, 9:08 p.m. UTC
* gnu/packages/busybox.scm (busybox)[arguments]<#:phases>[disable-timestamps]:
New phase.
---
 gnu/packages/busybox.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Danny Milosavljevic June 14, 2020, 11:06 a.m. UTC | #1
Patchset squashed and merged as commits c37dc30e61c56de1815750e52186c6de5be38ee9
and 4fdf3a2e6ef0d635e79aaf912c6997d2cd978835.
diff mbox series

Patch

diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index e3431aa31b..0d692c6586 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -45,6 +45,10 @@ 
     (arguments
      '(#:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'disable-timestamps
+           (lambda _
+             (setenv "KCONFIG_NOTIMESTAMP" "1")
+             #t))
          (add-before 'configure 'disable-taskset
            ;; This feature fails its tests in the build environment,
            ;; was default 'n' until after 1.26.2.