diff mbox series

[bug#41365,2/5] gnu: godot: Remove obsolete workaround for aarch64.

Message ID 20200517155520.26183-2-timotej.lazar@araneo.si
State Accepted
Headers show
Series Add superstarfighter | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Timotej Lazar May 17, 2020, 3:55 p.m. UTC
* gnu/packages/game-development.scm (godot)[arguments]: Remove -DNO_THREADS
from scons-flags as Godot now builds and runs without it on aarch64.
---
 gnu/packages/game-development.scm | 4 ----
 1 file changed, 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index dfa55b136f..d84b3fb24a 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1586,10 +1586,6 @@  games.")
     (arguments
      `(#:scons ,scons-python2
        #:scons-flags (list "platform=x11" "target=release_debug"
-                           ,@(if (string-prefix? "aarch64" (or (%current-target-system)
-                                                               (%current-system)))
-                               `("CCFLAGS=-DNO_THREADS")
-                               '())
                            ;; Avoid using many of the bundled libs.
                            ;; Note: These options can be found in the SConstruct file.
                            "builtin_bullet=no"