diff mbox series

[bug#41365,1/5] gnu: godot: Enable release build.

Message ID 20200517155520.26183-1-timotej.lazar@araneo.si
State Accepted
Headers show
Series Add superstarfighter | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Timotej Lazar May 17, 2020, 3:55 p.m. UTC
* gnu/packages/game-development.scm (godot)[arguments]: Set release_debug
target in #:scons-flags to enable optimized build.
---
 gnu/packages/game-development.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 26aa4f714b..dfa55b136f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1585,7 +1585,7 @@  games.")
     (build-system scons-build-system)
     (arguments
      `(#:scons ,scons-python2
-       #:scons-flags (list "platform=x11"
+       #:scons-flags (list "platform=x11" "target=release_debug"
                            ,@(if (string-prefix? "aarch64" (or (%current-target-system)
                                                                (%current-system)))
                                `("CCFLAGS=-DNO_THREADS")