diff mbox series

[bug#40677,08/30] gnu: libupnp: Bump to 1.8.6; change the download method to git-fetch; add missing dependencies.

Message ID 20200417003433.5608-8-tona_kosmicznego_smiecia@interia.pl
State Accepted
Headers show
Series [bug#40677,01/30] gnu: jami: Move Jami and its dependencies to jami.scm. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jan Wielkiewicz April 17, 2020, 12:34 a.m. UTC
---
 gnu/packages/upnp.scm | 17 ++++++++++++-----
 1 file changed, 12 insertions(+), 5 deletions(-)

Comments

Mathieu Othacehe April 18, 2020, 12:37 p.m. UTC | #1
Do not forget to add your copyright on top of the file.

> -      (method url-fetch)
> -      (uri (string-append "mirror://sourceforge/pupnp/pupnp/libUPnP%20"
> -                          version "/" name "-" version ".tar.bz2"))
> +      (method git-fetch)
> +      (uri (git-reference
> +	    (url "https://github.com/mrjimenez/pupnp.git")
> +	    (commit (string-append "release-" version))))

Seems that this url is redirected to https://github.com/pupnp/pupnp.

>        (sha256
>         (base32
> -        "0hzsd7rvfa87b4hxg9yj4xhdfxx9sp09r9sqdl3mqhvmcyw018y5"))))
> +        "1jlb6qh47513h2simy0zxia5q61w1c31mnwmjqpr2nf832lmnpk4"))))
> +       (native-inputs
> +	`(("autoconf" ,autoconf)
> +	  ("automake" ,automake)
> +	  ("libtool" ,libtool)
> +	  ("pkg-config" ,pkg-config)))

There's a mix of tab and space characters here.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index 8f3c887a68..be75b9068f 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -28,6 +28,7 @@ 
   #:use-module (gnu packages photo)
   #:use-module (gnu packages image)
   #:use-module (gnu packages mp3)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages python)
@@ -92,15 +93,21 @@  over IRC, instant messaging, network games, and most server software.")
 (define-public libupnp
   (package
     (name "libupnp")
-    (version "1.6.25")
+    (version "1.8.6")
     (source
      (origin
-      (method url-fetch)
-      (uri (string-append "mirror://sourceforge/pupnp/pupnp/libUPnP%20"
-                          version "/" name "-" version ".tar.bz2"))
+      (method git-fetch)
+      (uri (git-reference
+	    (url "https://github.com/mrjimenez/pupnp.git")
+	    (commit (string-append "release-" version))))
       (sha256
        (base32
-        "0hzsd7rvfa87b4hxg9yj4xhdfxx9sp09r9sqdl3mqhvmcyw018y5"))))
+        "1jlb6qh47513h2simy0zxia5q61w1c31mnwmjqpr2nf832lmnpk4"))))
+       (native-inputs
+	`(("autoconf" ,autoconf)
+	  ("automake" ,automake)
+	  ("libtool" ,libtool)
+	  ("pkg-config" ,pkg-config)))
     (build-system gnu-build-system)
     (arguments
      ;; The tests require a network device capable of multicasting which is