diff mbox series

[bug#40677,16/30] gnu: pjproject-jami: Add a new SFL patch.

Message ID 20200417003433.5608-16-tona_kosmicznego_smiecia@interia.pl
State Accepted
Headers show
Series [bug#40677,01/30] gnu: jami: Move Jami and its dependencies to jami.scm. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jan Wielkiewicz April 17, 2020, 12:34 a.m. UTC
---
 gnu/packages/jami.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Mathieu Othacehe April 18, 2020, 1 p.m. UTC | #1
> -                                                "disable_local_resolution"))
> +                                                "disable_local_resolution"
> +						"fix_assert_on_connection_attempt"))
>                 #t)))

This indentation is wrong here. You should not use tabulations. Also
this is over the 78 column limit. A trick to respect it would be to
introduce a line break between the '#:inputs' key above and let your
editor figure it out.

Mathieu
Jan Wielkiewicz April 19, 2020, 7:49 p.m. UTC | #2
On Sat, 18 Apr 2020 15:00:28 +0200
Mathieu Othacehe <m.othacehe@gmail.com> wrote:

> > -
> > "disable_local_resolution"))
> > +
> > "disable_local_resolution"
> > +						"fix_assert_on_connection_attempt"))
> >                 #t)))  
> 
> This indentation is wrong here. You should not use tabulations. Also
> this is over the 78 column limit. A trick to respect it would be to
> introduce a line break between the '#:inputs' key above and let your
> editor figure it out.
> 
> Mathieu

Is there a way to remove tabulations in emacs or to configure emacs so
that it won't use tabulations?

I tried to correct formatting using the ./etc/indent_code.el or
something, but could miss something.


Jan Wielkiewicz
Michael Rohleder April 19, 2020, 8:32 p.m. UTC | #3
Jan <tona_kosmicznego_smiecia@interia.pl> writes:
> Is there a way to remove tabulations in emacs or to configure emacs so
> that it won't use tabulations?

this should help:

(setq-default indent-tabs-mode nil)
diff mbox series

Patch

diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 9ec4b45a32..e28f97c4d9 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -164,7 +164,8 @@ 
                                                 "fix_ebusy_turn"
                                                 "ignore_ipv6_on_transport_check"
                                                 "fix_turn_connection_failure"
-                                                "disable_local_resolution"))
+                                                "disable_local_resolution"
+						"fix_assert_on_connection_attempt"))
                #t)))
          ;; TODO: We could use substitute-keyword-arguments instead of
          ;; repeating the phases from pjproject, but somehow it does