diff mbox series

[bug#40265] gnu: python-intervaltree: Update to 3.0.2.

Message ID 20200327235125.3250-1-kuba@kadziolka.net
State Accepted
Headers show
Series [bug#40265] gnu: python-intervaltree: Update to 3.0.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Maja Kądziołka March 27, 2020, 11:51 p.m. UTC
* gnu/packages/bioinformatics.scm (python-intervaltree): Update to 3.0.2.
[arguments]: Don't skip the tests.
---

It turns out I need python-intervaltree 3.0 as a dependency for one of
the packages I'm working on.

Cc: Ricardo - you added python-pygenometracks, the only dependent. Could
you re-test it, just in case?

 gnu/packages/bioinformatics.scm | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)

Comments

Marius Bakke March 31, 2020, 2:58 p.m. UTC | #1
Jakub Kądziołka <kuba@kadziolka.net> writes:

> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (add-before 'check 'import-mismatch-error-workaround
> +           (lambda _
> +             (setenv "PY_IGNORE_IMPORTMISMATCH" "1")
> +             #t)))))

Can you add a comment about what this does?

Also, I guess this package should be moved out of bioinformatics.scm,
assuming the software you are packaging is not bioinfo-related?
Efraim Flashner April 1, 2020, 5:47 a.m. UTC | #2
On Tue, Mar 31, 2020 at 04:58:43PM +0200, Marius Bakke wrote:
> Jakub Kądziołka <kuba@kadziolka.net> writes:
> 
> > +    (arguments
> > +     `(#:phases
> > +       (modify-phases %standard-phases
> > +         (add-before 'check 'import-mismatch-error-workaround
> > +           (lambda _
> > +             (setenv "PY_IGNORE_IMPORTMISMATCH" "1")
> > +             #t)))))
> 
> Can you add a comment about what this does?

It seems to me there is some import mismatch and this is a workaround
for it. I assume it's related to deprecated python naming/modules and
may break on a python upgrade. IMO the phase name is descriptive enough,
and I assume if we were to remove it then it'd make a lot more sense
after seeing the error message.

> 
> Also, I guess this package should be moved out of bioinformatics.scm,
> assuming the software you are packaging is not bioinfo-related?
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index da3fe1d2c9..a8e4c830ae 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -13548,17 +13549,22 @@  allowing the insertion of arbitrary types into the tree.")
 (define-public python-intervaltree
   (package
     (name "python-intervaltree")
-    (version "2.1.0")
+    (version "3.0.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "intervaltree" version))
        (sha256
         (base32
-         "02w191m9zxkcjqr1kv2slxvhymwhj3jnsyy3a28b837pi15q19dc"))))
+         "0wz234g6irlm4hivs2qzmnywk0ss06ckagwh15nflkyb3p462kyb"))))
     (build-system python-build-system)
-    ;; FIXME: error when collecting tests
-    (arguments '(#:tests? #f))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'import-mismatch-error-workaround
+           (lambda _
+             (setenv "PY_IGNORE_IMPORTMISMATCH" "1")
+             #t)))))
     (propagated-inputs
      `(("python-sortedcontainers" ,python-sortedcontainers)))
     (native-inputs