diff mbox series

[bug#39777,V5,13/14] gnu: python-cachy: Update to 0.3.0.

Message ID 20200321112629.20988-13-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#39777,V5,01/14] gnu: python-pexpect: Update to 4.8.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR March 21, 2020, 11:26 a.m. UTC
* gnu/packages/python-xyz.scm (python-cachy): Update to 0.3.0.
[arguments]: Run checks using pifpaf. [native-inputs]: Add memcached and
python-pifpaf.
---
 gnu/packages/python-xyz.scm | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index baaefe8552..f036b66aba 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11202,18 +11202,25 @@  strings require only one extra byte in addition to the strings themselves.")
 (define-public python-cachy
   (package
     (name "python-cachy")
-    (version "0.2.0")
+    (version "0.3.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "cachy" version))
        (sha256
         (base32
-         "0v6mjyhgx6j7ya20bk69cr3gdzdkdf6psay0h090rscclgji65dp"))))
+         "1cb9naly8ampzlky7h74n5wj628l7jkpsh0c0jz0namlrvs82r8q"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+             (lambda _ (invoke "pifpaf" "run" "memcached" "--port" "11211" "--" "pytest"))))))
     (native-inputs
-     `(("python-fakeredis" ,python-fakeredis)
+     `(("memcached" ,memcached)
+       ("python-fakeredis" ,python-fakeredis)
        ("python-flexmock" ,python-flexmock)
+       ("python-pifpaf" ,python-pifpaf)
        ("python-pytest" ,python-pytest)))
     (propagated-inputs
      `(("python-memcached" ,python-memcached)