diff mbox series

[bug#39777,V5,10/14] gnu: Add python-json-logger.

Message ID 20200321112629.20988-10-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#39777,V5,01/14] gnu: python-pexpect: Update to 4.8.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR March 21, 2020, 11:26 a.m. UTC
* gnu/packages/python-xyz.scm (python-json-logger): New public variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e27fea1957..33d41a294c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18412,3 +18412,24 @@  attributes.  Extended attributes extend the basic attributes of files
 and directories in the file system.  They are stored as name:data pairs
 associated with file system objects (files, directories, symlinks, etc).")
     (license license:expat)))
+
+(define-public python-json-logger
+  (package
+    (name "python-json-logger")
+    (version "0.1.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-json-logger" version))
+       (sha256
+        (base32
+         "10g2ya6nsvn5vxzvq2wb8q4d43i3d7756i5rxyjna6d0y9i138xp"))))
+    (build-system python-build-system)
+    (home-page
+     "http://github.com/madzak/python-json-logger")
+    (synopsis
+     "A python library adding a json log formatter")
+    (description "This library is provided to allow standard python logging to
+output log data as json objects.  With JSON we can make our logs more readable
+by machines and we can stop writing custom parsers for syslog type records.")
+    (license license:bsd-3)))