diff mbox series

[bug#39943,1/3] gnu: Add fmt-5.

Message ID 20200306094130.20695-1-mail@ambrevar.xyz
State Accepted
Headers show
Series WIP: Hyperledger Iroha | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Pierre Neidhardt March 6, 2020, 9:41 a.m. UTC
* gnu/packages/pretty-print.scm (fmt-5): New variable.
---
 gnu/packages/pretty-print.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 14fe7a1bef..74e60cbd2a 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -191,6 +191,20 @@  to @code{IOStreams}.")
     ;; The library is bsd-2, but documentation and tests include other licenses.
     (license (list bsd-2 bsd-3 psfl))))
 
+(define-public fmt-5                    ; fmt >= 6 API is not backward compatible.
+  (package
+    (inherit fmt)
+    (version "5.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/fmtlib/fmt")
+                    (commit version)))
+              (file-name (git-file-name (package-name fmt) version))
+              (sha256
+               (base32
+                "1hl9s69a5ql5nckc0ifh2fzlgsgv1wsn6yhqkpnrhasqkhj0hgv4"))))))
+
 (define-public source-highlight
   (package
     (name "source-highlight")