mbox series

[bug#39943,0/3] WIP: Hyperledger Iroha

Message ID 20200306092322.10256-1-mail@ambrevar.xyz
Headers show
Series WIP: Hyperledger Iroha | expand

Message

Pierre Neidhardt March 6, 2020, 9:23 a.m. UTC
It's close to build but fails with some unreadable C++ / Boost error.
I've reported upstream:

https://jira.hyperledger.org/browse/IR-689?jql=text%20~%20%22guix%22

Anyone proficient enough in C++ / Boost to solve this?

Pierre Neidhardt (3):
  gnu: Add fmt-5.
  gnu: Add hyperledger-iroha-ed25519.
  gnu: Add hyperledger-iroha.

 gnu/packages/hyperledger.scm                  | 125 +++++++++++++++++-
 ...oha-ed25519-cmake-remove-hunter-gate.patch |  23 ++++
 gnu/packages/pretty-print.scm                 |  14 ++
 3 files changed, 157 insertions(+), 5 deletions(-)
 create mode 100644 gnu/packages/patches/hyperledger-iroha-ed25519-cmake-remove-hunter-gate.patch

Comments

Efraim Flashner March 10, 2020, 8:31 a.m. UTC | #1
I fixed the boost errors by using boost-1.69, which of course is
suboptimal. There were other linking errors with grpc so I made it also
produce a shared library and adjusted tensorflow so the changes don't
break building that.

Efraim Flashner (2):
  gnu: grpc: Build shared libraries.
  gnu: Add boost-1.69.

Pierre Neidhardt (2):
  gnu: Add hyperledger-iroha-ed25519.
  gnu: Add hyperledger-iroha.

 gnu/packages/boost.scm            |  25 +++++-
 gnu/packages/hyperledger.scm      | 129 +++++++++++++++++++++++++++++-
 gnu/packages/machine-learning.scm |  43 +++++++++-
 3 files changed, 190 insertions(+), 7 deletions(-)