diff mbox series

[bug#39715,3/3] gnu: gnome-shell-extension-noannoyance: Use the copy-build-system.

Message ID 20200221163215.11008-3-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#39717,1/3] gnu: delft-icon-theme: Use the copy-build-system. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Prikler Feb. 21, 2020, 4:32 p.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-noannoyance):
Use the copy-build-system.
---
 gnu/packages/gnome-xyz.scm | 14 +++-----------
 1 file changed, 3 insertions(+), 11 deletions(-)

Comments

Pierre Neidhardt Feb. 27, 2020, 10:34 a.m. UTC | #1
Merged, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0f945fc19d..fa77fa79a7 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -279,18 +279,10 @@  into a single panel, similar to that found in KDE Plasma and Windows 7+.")
                (base32
                 "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
               (file-name (git-file-name name version))))
-    (build-system trivial-build-system)
+    (build-system copy-build-system)
     (arguments
-     '(#:modules ((guix build utils))
-       #:builder
-       (begin
-         (use-modules (guix build utils))
-         (let ((dst (string-append
-                     (assoc-ref %outputs "out")
-                     "/share/gnome-shell/extensions/"
-                     "noannoyance@daase.net")))
-           (mkdir-p dst)
-           (copy-recursively (assoc-ref %build-inputs "source") dst)))))
+     '(#:install-plan
+       '(("." "share/gnome-shell/extensions/noannoyance@daase.net"))))
     (synopsis "Removes 'Window is ready' annotation")
     (description "One of the many extensions, that remove this message.
 It uses ES6 syntax and claims to be more actively maintained than others.")