diff mbox series

[bug#39716,2/3] gnu: gnome-shell-extension-appindicator: Use the copy-build-system.

Message ID 20200221163215.11008-2-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#39717,1/3] gnu: delft-icon-theme: Use the copy-build-system. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Prikler Feb. 21, 2020, 4:32 p.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-appindicator):
Use the copy-build-system.
---
 gnu/packages/gnome-xyz.scm | 16 ++++------------
 1 file changed, 4 insertions(+), 12 deletions(-)

Comments

Pierre Neidhardt Feb. 27, 2020, 10:31 a.m. UTC | #1
Merged, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 882bd40c2e..0f945fc19d 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -129,19 +129,11 @@  the Obsidian icon theme.")
                (base32
                 "1fjhx23jqwv3d0smwhnjvc35gqhwk9p5f96ic22pfax653cn5vh8"))
               (file-name (git-file-name name version))))
-    (build-system trivial-build-system)
+    (build-system copy-build-system)
     (arguments
-     '(#:modules ((guix build utils))
-       #:builder
-       (begin
-         (use-modules (guix build utils))
-         (let* ((source (assoc-ref %build-inputs "source"))
-                (install-dir (string-append (assoc-ref %outputs "out")
-                                            "/share/gnome-shell/extensions"
-                                            "/appindicatorsupport@rgcjonas.gmail.com")))
-           (mkdir-p install-dir)
-           (copy-recursively source install-dir)
-           #t))))
+     `(#:install-plan
+       '(("." ,(string-append "share/gnome-shell/extensions/"
+                              "appindicatorsupport@rgcjonas.gmail.com")))))
     (synopsis "Adds KStatusNotifierItem support to GNOME Shell")
     (description "This extension integrates Ubuntu AppIndicators
 and KStatusNotifierItems (KDE's successor of the systray) into