diff mbox series

[bug#39128,09/12] gnu: Add python-iocapture.

Message ID 20200114015739.14432-9-julien@lepiller.eu
State Accepted
Headers show
Series [bug#39128,01/12] gnu: Add python-pyenchant. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Julien Lepiller Jan. 14, 2020, 1:57 a.m. UTC
* gnu/packages/python-xyz.scm (python-iocapture): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 56d98333ea..5041042a0c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17161,3 +17161,25 @@  files.  These files are used to translate strings in android apps.")
     (description "This package provides pattern matching and various utilities
 for file systems paths.")
     (license license:expat)))
+
+(define-public python-iocapture
+  (package
+    (name "python-iocapture")
+    (version "0.1.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "iocapture" version))
+        (sha256
+         (base32
+          "1s3ywdr0l3kfrrqi079iv16g0rp75akkvx0j07vx9p5w10c0wrw6"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-flexmock" ,python-flexmock)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/oinume/iocapture")
+    (synopsis "stdout and stderr capture in Python")
+    (description "This package allows Python developpers to capture their standard
+output and standard error.")
+    (license license:expat)))