diff mbox series

[bug#39128,10/12] gnu: Add python-argh.

Message ID 20200114015739.14432-10-julien@lepiller.eu
State Accepted
Headers show
Series [bug#39128,01/12] gnu: Add python-pyenchant. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Julien Lepiller Jan. 14, 2020, 1:57 a.m. UTC
* gnu/packages/python-xyz.scm (python-argh): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5041042a0c..0b818d12e5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17183,3 +17183,25 @@  for file systems paths.")
     (description "This package allows Python developpers to capture their standard
 output and standard error.")
     (license license:expat)))
+
+(define-public python-argh
+  (package
+    (name "python-argh")
+    (version "0.26.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "argh" version))
+        (sha256
+         (base32
+          "0rdv0n2aa181mkrybwvl3czkrrikgzd4y2cri6j735fwhj65nlz9"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-iocapture" ,python-iocapture)
+       ("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/neithere/argh/")
+    (synopsis "Argparse wrapper with natural syntax")
+    (description "This package provides a parser for dealing with command-line
+arguments in Python.")
+    (license license:lgpl3)))