diff mbox series

[bug#39006] gnu: timidity++: Add libvorbis as input

Message ID 20200107110830.25890-1-eu@euandre.org
State Accepted
Headers show
Series [bug#39006] gnu: timidity++: Add libvorbis as input | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

ashish.is--- via Guix-patches" via Jan. 7, 2020, 11:08 a.m. UTC
* gnu/packages/audio.scm (timidity++)[inputs] Add libvorbis as input
---
Hi Guix!

The current definition of TiMidity++ does include the configure flag for
Ogg Vorbis (--enable-audio=vorbis), but the package definition does not
provide all the required inputs for actually enabling it:

--8<---------------cut here---------------start------------->8---
$ guix environment --ad-hoc -- timidity -Ov
Playmode `v' is not compiled in.
Try timidity -h for help
--8<---------------cut here---------------end--------------->8---

From the build log (http://ci.guix.gnu.org/log/qynf65197fp921vz8k03qblz7djaarb0-timidity++-2.14.0):

--8<---------------cut here---------------start------------->8---
...
checking for Ogg... yes
checking for Vorbis... no
*** Could not run Vorbis test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means Vorbis was incorrectly installed
*** or that you have moved Vorbis since it was installed.
...
--8<---------------cut here---------------end--------------->8---

This happens because 'libogg' in provided as input, but 'libvorbis'
isn't.

After applying this patch, Ogg Vorbis becomes available like other formats.
--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix environment --ad-hoc -- timidity -Ov
Try timidity -h for help
--8<---------------cut here---------------end--------------->8---
 gnu/packages/audio.scm | 1 +
 1 file changed, 1 insertion(+)

--
2.24.1

Comments

Ludovic Courtès Jan. 11, 2020, 9:45 p.m. UTC | #1
Hello,

EuAndreh <eu@euandre.org> skribis:

> * gnu/packages/audio.scm (timidity++)[inputs] Add libvorbis as input
> ---
> Hi Guix!
>
> The current definition of TiMidity++ does include the configure flag for
> Ogg Vorbis (--enable-audio=vorbis), but the package definition does not
> provide all the required inputs for actually enabling it:
>
> $ guix environment --ad-hoc -- timidity -Ov
> Playmode `v' is not compiled in.
> Try timidity -h for help

Indeed.  Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 55a34460b1..f37ebc886e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2574,6 +2574,7 @@  Suil currently supports every combination of Gtk, Qt, and X11.")
        ("flac" ,flac)
        ("jack" ,jack-1)
        ("libogg" ,libogg)
+       ("libvorbis" ,libvorbis)
        ("speex" ,speex)
        ("ncurses" ,ncurses)
        ("freepats" ,freepats)))