diff mbox series

[bug#43823,2/3] gnu: knot: Build the Info manual.

Message ID 201a17b6e4fe8abb50cf759fe50db1b339b17657.1601941844.git.simon@simonsouth.net
State Accepted
Headers show
Series Knot: Enable DoH; build Info manual; work on aarch64-linux | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Simon South Oct. 6, 2020, 12:27 a.m. UTC
This also silences a configure warning about the "sphinx-build"
command being unavailable.

* gnu/packages/dns.scm (knot)[arguments]: Add "build-info" and
"install-info" phases.
[native-inputs]: Add texinfo and python-sphinx.
---
 gnu/packages/dns.scm | 13 +++++++++++--
 1 file changed, 11 insertions(+), 2 deletions(-)

Comments

ashish.is--- via Guix-patches" via Oct. 6, 2020, 1:10 a.m. UTC | #1
Simon,

Simon South 写道:
> This also silences a configure warning about the "sphinx-build"
> command being unavailable.

./configure is a noisy boy; not every ‘warning’ warrants action. 
A GNU info manual is definitely nice to have though!

> +       ("makeinfo" ,texinfo)
>         ("pkg-config" ,pkg-config)
> -       ("ragel" ,ragel)))
> +       ("ragel" ,ragel)
> +       ("sphinx-build" ,python-sphinx)))

It's a subjective line but I'd prefer the labels match the package 
here.  Nitpick, can be fixed up in post.

Otherwise LGTM,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index d791c45f69..0eab03fbbd 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -69,6 +69,7 @@ 
   #:use-module (gnu packages shells)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages swig)
+  #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xml)
@@ -841,6 +842,9 @@  Extensions} (DNSSEC).")
              ;; This is needed even when using ‘make config_dir=... install’.
              (substitute* "src/Makefile.in" (("\\$\\(INSTALL\\) -d") "true"))
              #t))
+         (add-after 'build 'build-info
+           (lambda _
+             (invoke "make" "info")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -848,13 +852,18 @@  Extensions} (DNSSEC).")
                     (etc (string-append doc "/examples/etc")))
                (invoke "make"
                        (string-append "config_dir=" etc)
-                       "install")))))))
+                       "install"))))
+         (add-after 'install 'install-info
+           (lambda _
+             (invoke "make" "install-info"))))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
        ("libtool" ,libtool)
+       ("makeinfo" ,texinfo)
        ("pkg-config" ,pkg-config)
-       ("ragel" ,ragel)))
+       ("ragel" ,ragel)
+       ("sphinx-build" ,python-sphinx)))
     (inputs
      `(("fstrm" ,fstrm)
        ("gnutls" ,gnutls)