diff mbox series

[bug#38637,2/4] gnu: Add python-argh.

Message ID 20191216152519.3595-2-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#38637,1/4] gnu: Add python-iocapture. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 16, 2019, 3:25 p.m. UTC
* gnu/packages/python-xyz.scm (python-argh): New variable.
---
 gnu/packages/python-xyz.scm | 37 ++++++++++++++++++++++++++++++++++++-
 1 file changed, 36 insertions(+), 1 deletion(-)

Comments

Ricardo Wurmus Dec. 16, 2019, 4:31 p.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/python-xyz.scm (python-argh): New variable.

Pushed to the “master” branch (commit db6bd842aa) with minor changes,
such as this one:

> +      (license license:lgpl3))))

It’s actually LGPLv3+.

Thank you!

--
Ricardo
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f26bc7719b..1f2149c9c4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16824,4 +16824,39 @@  services to what you expect in your tests.")
      (description
       "python-iocapture helps you to capture the standard out (stdout) and the
 standard error channel (stderr) in your program.")
-     (license license:expat)))) ; MIT license
\ No newline at end of file
+     (license license:expat)))) ; MIT license
+
+(define-public python-argh
+  ;; there are 21 commits after the latest release
+  ;; those contains important improvements
+  (let ((commit "dcd3253f2994400a6a58a700c118c53765bc50a4")
+        (revision "1"))
+    (package
+      (name "python-argh")
+      (version "0.26.2")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference (url "https://github.com/neithere/argh.git")
+                             (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1p5h3dnpbsjmqrvil96s71asc6i3gpinmbrabqmwnrsxprz7r3ns"))))
+      (build-system python-build-system)
+      (propagated-inputs
+       `(("python-iocapture" ,python-iocapture)
+         ("python-mock" ,python-mock)
+         ("python-pytest" ,python-pytest)
+         ("python-pytest-cov" ,python-pytest-cov)
+         ("python-pytest-xdist" ,python-pytest-xdist)
+         ("python-tox" ,python-tox)))
+      (home-page "https://github.com/neithere/argh/")
+      (synopsis "Argparse wrapper with natural syntax")
+      (description
+       "python-argh is a small library that provides several layers of
+abstraction on top of python-argparse.  The layers can be mixed.  It is always
+possible to declare a command with the highest possible (and least flexible)
+layer and then tune the behaviour with any of the lower layers including the
+native API of python-argparse.")
+      (license license:lgpl3))))