diff mbox series

[bug#38637,1/4] gnu: Add python-iocapture.

Message ID 20191216152519.3595-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#38637,1/4] gnu: Add python-iocapture. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 16, 2019, 3:25 p.m. UTC
* gnu/packages/python-xyz.scm (python-iocapture): New variable.
---
 gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Ricardo Wurmus Dec. 16, 2019, 4:27 p.m. UTC | #1
Hi Mădălin,

> * gnu/packages/python-xyz.scm (python-iocapture): New variable.

thanks for the patch!

> +(define-public python-iocapture
> +  ;; the latest is more than year newer than the latest realease

I know what you mean but that’s not what the comment says ;)  I
changed it.

> +  (let ((commit "fdc021c431d0840303908dfc3ca8769db383595c")
> +        (revision "1"))
> +    (package
> +     (name "python-iocapture")
> +     (version "0.1.2")
> +     (source
> +      (origin
> +       (method git-fetch)
> +       (uri (git-reference (url "https://github.com/oinume/iocapture.git")
> +                           (commit commit)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "1mkbhqibxvgwg0p7slr8dfraa3g2s6bsayladhax2jccwj4kcndz"))))
> +     (build-system python-build-system)
> +     (propagated-inputs
> +      `(("python-flexmock" ,python-flexmock)
> +        ("python-pytest" ,python-pytest)
> +        ("python-pytest-cov" ,python-pytest-cov)
> +        ("python-six" ,python-six)))
> +     (home-page "https://github.com/oinume/iocapture")
> +     (synopsis "Phython capuring tool for stdout and stderr")

Typos: Phython –> Python; capuring –> capturing

> +     (description
> +      "python-iocapture helps you to capture the standard out (stdout) and the
> +standard error channel (stderr) in your program.")
> +     (license license:expat)))) ; MIT license

The term “MIT license” is ambiguous, so we don’t use it, not even in a
comment.

I noticed that the tests were not actually run, so I overrode the check
phase.

I pushed this with modifications to the “master” branch with commit
dbcef44a0b.

Thanks again!

--
Ricardo
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 03dddcde43..f26bc7719b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -67,6 +67,7 @@ 
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -16795,3 +16796,32 @@  services to what you expect in your tests.")
 
 (define-public python2-ujson
   (package-with-python2 python-ujson))
+
+(define-public python-iocapture
+  ;; the latest is more than year newer than the latest realease
+  (let ((commit "fdc021c431d0840303908dfc3ca8769db383595c")
+        (revision "1"))
+    (package
+     (name "python-iocapture")
+     (version "0.1.2")
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference (url "https://github.com/oinume/iocapture.git")
+                           (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1mkbhqibxvgwg0p7slr8dfraa3g2s6bsayladhax2jccwj4kcndz"))))
+     (build-system python-build-system)
+     (propagated-inputs
+      `(("python-flexmock" ,python-flexmock)
+        ("python-pytest" ,python-pytest)
+        ("python-pytest-cov" ,python-pytest-cov)
+        ("python-six" ,python-six)))
+     (home-page "https://github.com/oinume/iocapture")
+     (synopsis "Phython capuring tool for stdout and stderr")
+     (description
+      "python-iocapture helps you to capture the standard out (stdout) and the
+standard error channel (stderr) in your program.")
+     (license license:expat)))) ; MIT license
\ No newline at end of file