diff mbox series

[bug#38319,3/4] gnu: python-pyqt: Fix output directory for plugins.

Message ID 20191122093730.6164-3-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Fix wrap-qt-program some packages using Qt | expand

Commit Message

Hartmut Goebel Nov. 22, 2019, 9:37 a.m. UTC
This defaults to QT_INSTALL_PLUGINS, thus we should use the same
sub-path ($out/lib/qt5/plugins) here.

* gnu/packages/qt.scm(python-pyqt)[arguments]<phases>{configure}:
  Change base path for plugins.
---
 gnu/packages/qt.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Courtès Nov. 25, 2019, 10:37 p.m. UTC | #1
Hartmut Goebel <h.goebel@crazy-compilers.com> skribis:

> This defaults to QT_INSTALL_PLUGINS, thus we should use the same
> sub-path ($out/lib/qt5/plugins) here.

“sub-directory”  :-)

> * gnu/packages/qt.scm(python-pyqt)[arguments]<phases>{configure}:
>   Change base path for plugins.

“base file name”

LGTM, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 5f4f29a948..ba6595cdfb 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1616,7 +1616,7 @@  module provides support functions to the automatically generated code.")
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin"))
                     (sip (string-append out "/share/sip"))
-                    (plugins (string-append out "/plugins"))
+                    (plugins (string-append out "/lib/qt5/plugins"))
                     (designer (string-append plugins "/designer"))
                     (qml (string-append plugins "/PyQt5"))
                     (python (assoc-ref inputs "python"))