diff mbox series

[bug#38319,1/4] gnu: sddm: Fix output directory for QML files.

Message ID 20191122093730.6164-1-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Fix wrap-qt-program some packages using Qt | expand

Commit Message

Hartmut Goebel Nov. 22, 2019, 9:37 a.m. UTC
Path must match qtbase's native-search-path specification, otherwise it
will not be picked up by other packages.

* gnu/packages/display-managers.scm(sddm)[arguments]<configure-flags>:
  Change value of "-DQT_IMPORTS_DIR".
---
 gnu/packages/display-managers.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Courtès Nov. 25, 2019, 10:35 p.m. UTC | #1
Hartmut Goebel <h.goebel@crazy-compilers.com> skribis:

> Path must match qtbase's native-search-path specification, otherwise it
> will not be picked up by other packages.
>
> * gnu/packages/display-managers.scm(sddm)[arguments]<configure-flags>:
>   Change value of "-DQT_IMPORTS_DIR".

LGTM!
diff mbox series

Patch

diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 0b8f742c38..21afc0ec5c 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -102,7 +102,7 @@ 
                        (assoc-ref %build-inputs "shadow")
                        "/etc/login.defs")
         (string-append "-DQT_IMPORTS_DIR="
-                       (assoc-ref %outputs "out") "/qml")
+                       (assoc-ref %outputs "out") "/lib/qt5/qml")
         (string-append "-DCMAKE_INSTALL_SYSCONFDIR="
                        (assoc-ref %outputs "out") "/etc"))
        #:modules ((guix build cmake-build-system)