diff mbox series

[bug#38099,3/3] gnu: Deprecate kdevplatform package.

Message ID 20191107102550.3721-3-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Upate kdevelop to 5.4.4 and deprecate kdevplatform package | expand

Commit Message

Hartmut Goebel Nov. 7, 2019, 10:25 a.m. UTC
* gnu/packages/kde.scm (qt-4kdevplatform): Define as a deprecated alias
  for 'kdevelop`.
---
 gnu/packages/kde.scm | 74 ++------------------------------------------
 1 file changed, 3 insertions(+), 71 deletions(-)

Comments

Efraim Flashner Nov. 7, 2019, 12:37 p.m. UTC | #1
On Thu, Nov 07, 2019 at 11:25:50AM +0100, Hartmut Goebel wrote:
> * gnu/packages/kde.scm (qt-4kdevplatform): Define as a deprecated alias
>   for 'kdevelop`.
> ---

qt-4kdevplatform looks like a typo

> +;; kdevplatform was merged into kdevelop as of 5.2.x
> +(define-deprecated kdevplatform `kdevelop kdevelop)
>  
should probably be
(define-deprecated kdevplatform kdevelop kdevelop)
Hartmut Goebel Nov. 7, 2019, 5:03 p.m. UTC | #2
Am 07.11.19 um 13:37 schrieb Efraim Flashner:
> On Thu, Nov 07, 2019 at 11:25:50AM +0100, Hartmut Goebel wrote:
>> * gnu/packages/kde.scm (qt-4kdevplatform): Define as a deprecated alias
>>   for 'kdevelop`.
>> ---
> qt-4kdevplatform looks like a typo

ACK


>> +;; kdevplatform was merged into kdevelop as of 5.2.x
>> +(define-deprecated kdevplatform `kdevelop kdevelop)
>>  
> should probably be
> (define-deprecated kdevplatform kdevelop kdevelop)

Ups, I inherited this from 02511196d99ebc5e385e9dc7f733ffbe848e25ca.
Going to fix that, too.
diff mbox series

Patch

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 923af4381d..8ae8d5b3ca 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -25,6 +25,7 @@ 
 
 (define-module (gnu packages kde)
   #:use-module (guix build-system cmake)
+  #:use-module (guix deprecation)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
@@ -274,77 +275,8 @@  software (Git, Subversion, Mercurial, CVS and Bazaar).")
 for some KDevelop language plugins (Ruby, PHP, CSS...).")
     (license license:lgpl2.0+)))
 
-(define-public kdevplatform
-  (package
-    (name "kdevplatform")
-    (version "5.1.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://kde/stable/kdevelop"
-                                  "/" version "/src/kdevplatform-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "0jk6g1kiqpyjy8pca0236b9944gxqnymqv8ny6m8nrraannxs8p6"))))
-    (build-system cmake-build-system)
-    (native-inputs
-     `(("extra-cmake-modules" ,extra-cmake-modules)
-       ("pkg-config" ,pkg-config)))
-    (inputs
-     `(("apr" ,apr)
-       ("apr-util" ,apr-util)
-       ("boost" ,boost)
-       ("karchive" ,karchive)
-       ("kconfigwidgets" ,kconfigwidgets)
-       ("kcmutils" ,kcmutils)
-       ("kiconthemes" ,kiconthemes)
-       ("kdeclarative" ,kdeclarative)
-       ("kdoctools" ,kdoctools)
-       ("kguiaddons" ,kguiaddons)
-       ("kinit" ,kinit)
-       ("kitemmodels" ,kitemmodels)
-       ("knewstuff" ,knewstuff)
-       ("knotifications" ,knotifications)
-       ("knotifyconfig" ,knotifyconfig)
-       ("kwindowsystem" ,kwindowsystem)
-       ("kio" ,kio)
-       ("ki18n" ,ki18n)
-       ("kparts" ,kparts)
-       ("kservice" ,kservice)
-       ("grantlee" ,grantlee)
-       ("libkomparediff2" ,libkomparediff2)
-       ("sonnet" ,sonnet)
-       ("threadweaver" ,threadweaver)
-       ("ktexteditor" ,ktexteditor)
-       ("qtbase" ,qtbase)
-       ("qtdeclarative" ,qtdeclarative)
-       ("qtscript" ,qtscript)
-       ("qtwebkit" ,qtwebkit)
-       ("qtx11extras" ,qtx11extras)
-       ("plasma" ,plasma-framework)
-       ("subversion" ,subversion)
-       ("zlib" ,zlib)))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (delete 'check)
-         (add-after 'install 'check
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
-               (setenv "QT_PLUGIN_PATH"
-                       (string-append out "/lib/plugins:"
-                                      (getenv "QT_PLUGIN_PATH")))
-               (setenv "XDG_DATA_DIRS"
-                       (string-append out "/share:"
-                                      (getenv "XDG_DATA_DIRS")))
-               (invoke "ctest" "-R" ; almost all tests require a display
-                       "filteringstrategy|kdevvarlengtharray|kdevhash")))))))
-    (home-page "https://github.com/KDE/kdevplatform")
-    (synopsis "Framework to build integrated development environments (IDEs)")
-    (description "KDevPlatform is the basis of KDevelop and contains some
-plugins, as well as code to create plugins, or complete applications.")
-    (license license:gpl3+)))
+;; kdevplatform was merged into kdevelop as of 5.2.x
+(define-deprecated kdevplatform `kdevelop kdevelop)
 
 (define-public krita
   (package