diff mbox series

[bug#38099,2/3] gnu: kdevelop: Update to 5.4.4.

Message ID 20191107102550.3721-2-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Upate kdevelop to 5.4.4 and deprecate kdevplatform package | expand

Commit Message

Hartmut Goebel Nov. 7, 2019, 10:25 a.m. UTC
* gnu/packages/kde.scm(kdevelop): Update to 5.4.4.
  [inputs] Remove kconfig, kdevplatform, libepoxy; Add apr, apr-util, astyle,
  attica, boost, kconfigwidgets, kservice, libkomparediff2, sonnet,
  subversion; structure and sort.
  [arguments]<phases>{add-include-path}: New phase.
  {wrap-executable}: Remove references to kdevplatform.
---
 gnu/packages/kde.scm | 74 ++++++++++++++++++++++++++++++--------------
 1 file changed, 50 insertions(+), 24 deletions(-)

Comments

Efraim Flashner Nov. 7, 2019, 12:36 p.m. UTC | #1
I suggest you try out swapping out the majority of wrap-program and take
a look at wrap-qt-program from (guix build qt-utils), which should take
care of the different qt variables.
Hartmut Goebel Nov. 7, 2019, 4:53 p.m. UTC | #2
Am 07.11.19 um 13:36 schrieb Efraim Flashner:
> I suggest you try out swapping out the majority of wrap-program and take
> a look at wrap-qt-program from (guix build qt-utils), which should take
> care of the different qt variables.

wrap-qt-program sound good, but I#m afraid, it is

a) insufficient in this case, since it does not cover
QT_QPA_PLATFORM_PLUGIN_PATH, which seems to require

b) looks faulty, since it adds paths $out/qml and $out/plugins, which
are wrong (even if they exit in e.g. sddm)

But I will model the code here along the lines of wrap-qt-program, thus
easing migration to wrap-qt-program somewhen later.
Hartmut Goebel Nov. 8, 2019, 10:41 a.m. UTC | #3
kdevelop has some other issues, too, which inhibits testing it. Thus
completing the patch will take some time.

Esp. it depends on <http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38123>
qtwebkit: Use sqlite-with-column-metadata.
Hartmut Goebel Dec. 11, 2019, 10:57 a.m. UTC | #4
Thanks for the review.

I finally push this as e87b83b62c2d21e0efc4ae62a115405aeef756a6.

I fixed the errors Efrain reported and also based kdevelop on the (new)
qt-build-system) - which avoids `wrap-program` here,

I also took the change and updated to 5.4.5
diff mbox series

Patch

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 6afc2c5eba..923af4381d 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -33,6 +33,7 @@ 
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages apr)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages code)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages documentation)
@@ -140,7 +141,7 @@  projects.")
 (define-public kdevelop
   (package
     (name "kdevelop")
-    (version "5.1.2")
+    (version "5.4.4")
     (source
       (origin
         (method url-fetch)
@@ -149,55 +150,80 @@  projects.")
                             version ".tar.xz"))
         (sha256
          (base32
-          "1iqaq0ilijjigqb34v5wq9in6bnjs0p9cmgbygjmy53xhh3yhm5g"))))
+          "1cangz3ghz39sxxggp2p7kqy2ncgs0r3i19c341b5xbkcxw2y20h"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)
        ("qttools" ,qttools)))
     (inputs
-     `(("kdevplatform" ,kdevplatform)
-       ("kdevelop-pg-qt" ,kdevelop-pg-qt)
-       ("qtbase" ,qtbase)
-       ("qtdeclarative" ,qtdeclarative)
-       ("qtquickcontrols" ,qtquickcontrols)
-       ("qtwebkit" ,qtwebkit)
+     `(("boost" ,boost)
+       ("clang" ,clang)
+       ("grantlee" ,grantlee)
        ("karchive" ,karchive)
        ("kcmutils" ,kcmutils)
-       ("kconfig" ,kconfig)
+       ("kcrash" ,kcrash)
        ("kdeclarative" ,kdeclarative)
        ("kdoctools" ,kdoctools)
        ("kguiaddons" ,kguiaddons)
        ("ki18n" ,ki18n)
-       ("kio" ,kio)
        ("kiconthemes" ,kiconthemes)
+       ("kio" ,kio)  ;; not checked as requirement
        ("kitemmodels" ,kitemmodels)
        ("kitemviews" ,kitemviews)
        ("kjobwidgets" ,kjobwidgets)
-       ("knotifyconfig" ,knotifyconfig)
        ("knotifications" ,knotifications)
+       ("knotifyconfig" ,knotifyconfig)
        ("kparts" ,kparts)
-       ("kcrash" ,kcrash)
-       ("knewstuff" ,knewstuff)
-       ("krunner" ,krunner)
-       ("kxmlgui" ,kxmlgui)
-       ("libksysguard" ,libksysguard)
-       ("threadweaver" ,threadweaver)
+       ("kservice" ,kservice)
        ("ktexteditor" ,ktexteditor)
        ("kwindowsystem" ,kwindowsystem)
+       ("kxmlgui" ,kxmlgui)
+       ("libkomparediff2" ,libkomparediff2)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtquickcontrols" ,qtquickcontrols)  ;; not checked as requirement
+       ("qtwebkit" ,qtwebkit)
+       ("shared-mime-info" ,shared-mime-info)
+       ("threadweaver" ,threadweaver)
+
+       ;; recommendes
+       ("astyle" ,astyle)
+       ("kdevelop-pg-qt" ,kdevelop-pg-qt)
+       ("libksysguard" ,libksysguard)
+
+       ;; optional
+       ("apr" ,apr)            ; required for subversion support
+       ("apr-util" ,apr-util)  ; required for subversion support
+       ("attica" ,attica)
+       ("kconfigwidgets" ,kconfigwidgets)
+       ("knewstuff" ,knewstuff)
+       ("krunner" ,krunner)
        ("plasma" ,plasma-framework)
-       ("grantlee" ,grantlee)
-       ("libepoxy" ,libepoxy)
-       ("clang" ,clang)
-       ("shared-mime-info" ,shared-mime-info)))
+       ("sonnet" ,sonnet)
+       ("subversion" ,subversion)
+       ;; TODO: OktetaGui, OktetaKastenControllers
+       ;; TODO: purpose
+
+       ;; run-time packages - TODO
+       ;; ClazyStandalone
+       ;; Cppcheck
+       ;; heaptrack
+       ;; heaptrack_gui
+       ;; meson
+       ))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'add-include-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "cmake/modules/FindClang.cmake"
+               (("^\\s*PATHS \"\\$\\{CLANG_LIBRARY_DIRS\\}\"" line)
+                (string-append line " " (assoc-ref inputs "clang") "/lib")))))
          (delete 'check) ;; there are some issues with the test suite
          (add-after 'install 'wrap-executable
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out  (assoc-ref outputs "out"))
-                    (kdevplatform (assoc-ref inputs "kdevplatform"))
                     (kio (assoc-ref inputs "kio"))
                     (kcmutils (assoc-ref inputs "kcmutils"))
                     (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
@@ -207,12 +233,12 @@  projects.")
                (wrap-program (string-append out "/bin/kdevelop")
                  `("XDG_DATA_DIRS" ":" prefix
                    ,(map (lambda (s) (string-append s "/share"))
-                         (list out kdevplatform kcmutils)))
+                         (list out kcmutils)))
                  `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
                    (,(string-append qtbase "/plugins/platforms")))
                  `("QT_PLUGIN_PATH" ":" prefix
                    ,(map (lambda (s) (string-append s "/lib/plugins"))
-                         (list out kdevplatform kio)))
+                         (list out kio)))
                  `("QML2_IMPORT_PATH" ":" prefix
                    (,(string-append qtquickcontrols qml)
                     ,(string-append qtdeclarative qml))))))))))