diff mbox series

[bug#38098,2/2] gnu: astyle: Install header file, too.

Message ID 20191107101810.3284-2-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Fix build for astyle | expand

Commit Message

Hartmut Goebel Nov. 7, 2019, 10:18 a.m. UTC
* gnu/packages/code.scm(astyle)[arguments]<phases>{install-libs}: Also
  install header file.
---
 gnu/packages/code.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index a277434b36..ba350b98e5 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -609,8 +609,9 @@  Objective@tie{}C, D, Java, Pawn, and Vala).  Features:
            (lambda _ (chdir "build/gcc") #t))
          (add-after 'install 'install-libs
            (lambda* (#:key outputs #:allow-other-keys)
-             ;; Libraries are not installed by default
+             ;; Libraries and includes are not installed by default
              (let* ((output (assoc-ref outputs "out"))
+                    (incdir (string-append output "/include"))
                     (libdir (string-append output "/lib")))
                (define (make-so-link sofile strip-pattern)
                  (symlink
@@ -618,6 +619,9 @@  Objective@tie{}C, D, Java, Pawn, and Vala).  Features:
                   (regexp-substitute #f
                                      (string-match strip-pattern sofile)
                                      'pre)))
+               (mkdir-p incdir)
+               (copy-file "../../src/astyle.h"
+                          (string-append incdir "/astyle.h"))
                (mkdir-p libdir)
                (for-each (lambda (l)
                            (copy-file