diff mbox series

[bug#38098,1/2] gnu: astyle: Create symlinks for .so files, too.

Message ID 20191107101810.3284-1-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Fix build for astyle | expand

Commit Message

Hartmut Goebel Nov. 7, 2019, 10:18 a.m. UTC
The Makefile only creates files with a versioned extension (.so.3.1.0),
which are not picked up be cmake's `find_libarary()`. (Instead cmake
picks up the static .a library.)

Symlinks for .so.3 are required to avoid phase `verify-runpath` fails.

* gnu/packages/code.scm(astyle)[argumements]<modules>: New element.
  <phases>{install-libs}: Add creating symlinks.
---
 gnu/packages/code.scm | 26 ++++++++++++++++++++------
 1 file changed, 20 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 512ca5d365..a277434b36 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2019 Hartmut Goebel <h.goebel@goebel-consult.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -599,6 +600,9 @@  Objective@tie{}C, D, Java, Pawn, and Vala).  Features:
        #:make-flags (list (string-append "prefix=" %output)
                           "INSTALL=install"
                           "all")
+       #:modules ((guix build gnu-build-system) ;; FIXME use %default-modules
+                  (guix build utils)
+                  (ice-9 regex))
        #:phases
        (modify-phases %standard-phases
          (replace 'configure
@@ -608,12 +612,22 @@  Objective@tie{}C, D, Java, Pawn, and Vala).  Features:
              ;; Libraries are not installed by default
              (let* ((output (assoc-ref outputs "out"))
                     (libdir (string-append output "/lib")))
-               (begin
-                 (mkdir-p libdir)
-                 (for-each (lambda (l)
-                             (copy-file
-                              l (string-append libdir "/" (basename l))))
-                           (find-files "bin" "lib*"))))
+               (define (make-so-link sofile strip-pattern)
+                 (symlink
+                  (basename sofile)
+                  (regexp-substitute #f
+                                     (string-match strip-pattern sofile)
+                                     'pre)))
+               (mkdir-p libdir)
+               (for-each (lambda (l)
+                           (copy-file
+                            l (string-append libdir "/" (basename l))))
+                         (find-files "bin" "lib*"))
+               (for-each
+                (lambda (sofile)
+                  (make-so-link sofile "(\\.[0-9]){3}$")  ;; link .so
+                  (make-so-link sofile "(\\.[0-9]){2}$")) ;; link .so.3
+                (find-files libdir "lib.*\\.so\\..*")))
              #t)))))
     (home-page "http://astyle.sourceforge.net/")
     (synopsis "Source code indenter, formatter, and beautifier")