diff mbox series

[bug#38030,04/13] gnu: Add kcalendarcore.

Message ID 20191102090950.18043-4-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update KDE frameworks and other KDE stuff | expand

Commit Message

Hartmut Goebel Nov. 2, 2019, 9:09 a.m. UTC
This is now a part of KDE Frameworks.

* gnu/packages/kde-frameworks.scm(kcalendarcore): New variable.
---
 gnu/packages/kde-frameworks.scm | 60 +++++++++++++++++++++++++++++++++
 1 file changed, 60 insertions(+)

Comments

Marius Bakke Nov. 3, 2019, 4:08 p.m. UTC | #1
Hartmut Goebel <h.goebel@crazy-compilers.com> writes:

> This is now a part of KDE Frameworks.
>
> * gnu/packages/kde-frameworks.scm(kcalendarcore): New variable.

[...]

> +(define-public kcalendarcore
> +  (package
> +    (name "kcalendarcore")
> +    (version "5.63.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> +                    "mirror://kde/stable/frameworks/"
> +                    (version-major+minor version) "/"
> +                    name "-" version ".tar.xz"))
> +              (sha256
> +               (base32
> +                "1cqqwpd6faz7sd6jrda564xxvwr231b175h2w3ilxx6hvz9yrps3"))))
> +    (build-system cmake-build-system)
> +    (native-inputs
> +     `(("extra-cmake-modules" ,extra-cmake-modules)
> +       ("perl" ,perl)
> +       ("tzdata" ,tzdata)))

This should use 'tzdata-for-tests'.

> +    (inputs
> +     `(("libical" ,libical)
> +       ("qtbase" ,qtbase)))
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (add-before 'configure 'disable-failing-libical3-tests
> +           (lambda _
> +             (substitute* "autotests/CMakeLists.txt"
> +               (("macro_unit_tests\\(testicaltimezones\\)" line)
> +                (string-append "## " line))
> +               (("target_link_libraries\\(testicaltimezones " line)
> +                (string-append "## " line)))
> +             (for-each
> +              delete-file
> +              (list
> +               "autotests/data/Compat-libical3/AppleICal_1.5.ics"
> +               "autotests/data/Compat-libical3/Evolution_2.8.2_timezone_test.ics"
> +               "autotests/data/Compat-libical3/KOrganizer_3.1a.ics"
> +               "autotests/data/Compat-libical3/MSExchange.ics"
> +               "autotests/data/Compat-libical3/Mozilla_1.0.ics"))
> +             #t))

Can you add some comments about why this is necessary?
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 85c3736669..cc9066d445 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -38,6 +38,7 @@ 
   #:use-module (gnu packages boost)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages calendar)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages disk)
@@ -429,6 +430,65 @@  GZip format, via a subclass of QIODevice.")
     (license (list license:lgpl2.1 license:lgpl2.1+
                    license:lgpl3+ license:bsd-2))))
 
+(define-public kcalendarcore
+  (package
+    (name "kcalendarcore")
+    (version "5.63.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1cqqwpd6faz7sd6jrda564xxvwr231b175h2w3ilxx6hvz9yrps3"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("perl" ,perl)
+       ("tzdata" ,tzdata)))
+    (inputs
+     `(("libical" ,libical)
+       ("qtbase" ,qtbase)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'disable-failing-libical3-tests
+           (lambda _
+             (substitute* "autotests/CMakeLists.txt"
+               (("macro_unit_tests\\(testicaltimezones\\)" line)
+                (string-append "## " line))
+               (("target_link_libraries\\(testicaltimezones " line)
+                (string-append "## " line)))
+             (for-each
+              delete-file
+              (list
+               "autotests/data/Compat-libical3/AppleICal_1.5.ics"
+               "autotests/data/Compat-libical3/Evolution_2.8.2_timezone_test.ics"
+               "autotests/data/Compat-libical3/KOrganizer_3.1a.ics"
+               "autotests/data/Compat-libical3/MSExchange.ics"
+               "autotests/data/Compat-libical3/Mozilla_1.0.ics"))
+             #t))
+         (add-before 'check 'set-timezone
+           (lambda* (#:key inputs #:allow-other-keys)
+             (setenv "TZ" "Europe/Prague")
+             (setenv "TZDIR"
+                     (string-append (assoc-ref inputs "tzdata")
+                                    "/share/zoneinfo"))
+             #t)))))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Library for interfacing with calendars")
+    (description "This library provides access to and handling of calendar
+data.  It supports the standard formats iCalendar and vCalendar and the group
+scheduling standard iTIP.
+
+A calendar contains information like incidences (events, to-dos, journals),
+alarms, time zones, and other useful information.  This API provides access to
+that calendar information via well known calendar formats iCalendar (or iCal)
+and the older vCalendar.")
+    (license (list license:lgpl3+ license:bsd-2))))
+
 (define-public kcodecs
   (package
     (name "kcodecs")