diff mbox series

[bug#38030,13/13] gnu: kpmcore: Update to 4.0.1

Message ID 20191102090950.18043-13-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update KDE frameworks and other KDE stuff | expand

Commit Message

Hartmut Goebel Nov. 2, 2019, 9:09 a.m. UTC
Also move to kde.scm, since it is a frameworks part.

* gnu/packages/kde-frameworks.scm(kpmcore): Move from here …
* gnu/packages/kde.scm(kpmcore): … to here, update to 4.0.1; [inputs]: Add
  qttools; [native-inputs]: Add dbus; [arguments]: New element.
---
 gnu/packages/kde-frameworks.scm | 33 ----------------------
 gnu/packages/kde.scm            | 49 +++++++++++++++++++++++++++++++++
 2 files changed, 49 insertions(+), 33 deletions(-)

Comments

Miguel Arruga Vivas Nov. 2, 2019, 6:38 p.m. UTC | #1
Hi Hartmut,

Just a couple of comments (although I'm not an official reviewer) about
this patch.

Hartmut Goebel <h.goebel@crazy-compilers.com> wrote:
> Also move to kde.scm, since it is a frameworks part.
> 
> * gnu/packages/kde-frameworks.scm(kpmcore): Move from here …
> * gnu/packages/kde.scm(kpmcore): … to here, update to 4.0.1;
> [inputs]: Add qttools; [native-inputs]: Add dbus; [arguments]: New
> element.

You moved kholidays to kde-frameworks.scm as it is now part of
the framework, but this comment seems to suggest that the framework
parts are located in kde.scm.  Is there any reason to not keep it there?

> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'check
> +           (lambda _
> +             ;(setenv "HOME" (getcwd))
> +             ;(setenv "TMPDIR" (getcwd))
> +             ;(setenv "QT_QPA_PLATFORM" "offscreen")
> +             (invoke "dbus-launch" "ctest" "."))))))

That commented code seems a left over from previous tests.  Perhaps
it should be removed, perhaps a comment makes sense there. :)

Best regards,
Miguel
Hartmut Goebel Nov. 3, 2019, 10:13 a.m. UTC | #2
Am 02.11.19 um 19:38 schrieb Miguel Arruga Vivas:
> Hartmut Goebel <h.goebel@crazy-compilers.com> wrote:
>> Also move to kde.scm, since it is a frameworks part.
> You moved kholidays to kde-frameworks.scm as it is now part of
> the framework, but this comment seems to suggest that the framework
> parts are located in kde.scm.  Is there any reason to not keep it there?

Oops the commit message is wrong, I will update it just after sending
this mail:

This should read: kpmcore is *not* a framework. Thus I moved it from
kde-frameworks.scm to kde.scm.


> That commented code seems a left over from previous tests. Perhaps
> it should be removed, perhaps a comment makes sense there. :)

You are absolutely right on this.  These comments are left-overs which
should never have gone there. I simply did not review the ackage
definition.
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 0b027f3118..46d1e3e3fc 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -41,7 +41,6 @@ 
   #:use-module (gnu packages calendar)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages databases)
-  #:use-module (gnu packages disk)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages freedesktop)
@@ -214,38 +213,6 @@  Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
     ;; license: source files mention "either version 2.1 or 3"
     (license (list license:lgpl2.1 license:lgpl3))))
 
-(define-public kpmcore
-  (package
-    (name "kpmcore")
-    (version "3.3.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "mirror://kde/stable/kpmcore"
-                    "/" version "/src/"
-                    name "-" version ".tar.xz"))
-              (sha256
-               (base32
-                "0s6v0jfrhjg31ri5p6h9n4w29jvasf5dj954j3vfpzl91lygmmmq"))))
-    (build-system cmake-build-system)
-    (native-inputs
-     `(("extra-cmake-modules" ,extra-cmake-modules)
-       ("pkg-config" ,pkg-config)))
-    (inputs
-     `(("kconfigwidgets" ,kconfigwidgets)
-       ("kiconthemes" ,kiconthemes)
-       ("kio" ,kio)
-       ("ki18n" ,ki18n)
-       ("kservice" ,kservice)
-       ("libatasmart" ,libatasmart)
-       ("parted" ,parted)
-       ("qtbase" ,qtbase)
-       ("util-linux" ,util-linux)))
-    (home-page "https://community.kde.org/Frameworks")
-    (synopsis "Library for managing partitions")
-    (description "Library for managing partitions.")
-    (license license:gpl3+)))
-
 
 ;; Tier 1
 ;;
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 0dacd5ce9e..c046327216 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,10 +1,12 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -33,15 +35,19 @@ 
   #:use-module (gnu packages boost)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
+  #:use-module (gnu packages disk)
   #:use-module (gnu packages documentation)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages image)
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages kde-plasma)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages llvm)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages pdf)
@@ -465,6 +471,49 @@  including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
 cards.")
     (license license:lgpl2.1)))
 
+(define-public kpmcore
+  (package
+    (name "kpmcore")
+    (version "4.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/kpmcore"
+                    "/" version "/src/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1sslkwcj2cyrn7bpjdjdwikp1q8wrsxpsg2sxxd8hsairgy7ygh3"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             ;(setenv "HOME" (getcwd))
+             ;(setenv "TMPDIR" (getcwd))
+             ;(setenv "QT_QPA_PLATFORM" "offscreen")
+             (invoke "dbus-launch" "ctest" "."))))))
+    (native-inputs
+     `(("dbus" ,dbus)
+       ("extra-cmake-modules" ,extra-cmake-modules)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("kconfigwidgets" ,kconfigwidgets)
+       ("kiconthemes" ,kiconthemes)
+       ("kio" ,kio)
+       ("ki18n" ,ki18n)
+       ("kservice" ,kservice)
+       ("libatasmart" ,libatasmart)
+       ("parted" ,parted)
+       ("qtbase" ,qtbase)
+       ("qca" ,qca)
+       ("util-linux" ,util-linux)))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Library for managing partitions")
+    (description "Library for managing partitions.")
+    (license license:gpl3+)))
+
 (define-public snorenotify
   (package
     (name "snorenotify")