diff mbox series

[bug#36026,4/4] gnu: python-conda: Update to 4.7.0.

Message ID 20190531140444.3810-4-mail@ambrevar.xyz
State Accepted
Headers show
Series Update Conda | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Pierre Neidhardt May 31, 2019, 2:04 p.m. UTC
* gnu/packages/package-management.scm (python-conda): Update to 4.7.0.
---
 gnu/packages/package-management.scm | 45 +++++++----------------------
 1 file changed, 10 insertions(+), 35 deletions(-)

Comments

Ricardo Wurmus June 13, 2019, 6:59 p.m. UTC | #1
Pierre Neidhardt <mail@ambrevar.xyz> writes:

> * gnu/packages/package-management.scm (python-conda): Update to 4.7.0.
[…]
> -         (add-before 'check 'remove-failing-tests
> -           (lambda _
> -             ;; These tests require internet/network access
> -             (let ((network-tests '("test_cli.py"
> -                                    "test_create.py"
> -                                    "test_export.py"
> -                                    "test_fetch.py"
> -                                    "test_history.py"
> -                                    "test_info.py"
> -                                    "test_install.py"
> -                                    "test_priority.py"
> -                                    "conda_env/test_cli.py"
> -                                    "conda_env/test_create.py"
> -                                    "conda_env/specs/test_notebook.py"
> -                                    "conda_env/utils/test_notebooks.py"
> -                                    "core/test_index.py"
> -                                    "core/test_repodata.py")))
> -               (with-directory-excursion "tests"
> -                 (for-each delete-file network-tests)
> -
> -                 ;; FIXME: This test creates a file, then deletes it and tests
> -                 ;; that the file was deleted.  For some reason it fails when
> -                 ;; building with guix, but does not when you run it in the
> -                 ;; directory left when you build with the --keep-failed
> -                 ;; option
> -                 (delete-file "gateways/disk/test_delete.py")
> -                 #t))))

Do none of the tests now require network access?  Are the tests actually
still run?

--
Ricardo
diff mbox series

Patch

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 28e23fd1d3..fb84f9abfc 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -755,16 +755,17 @@  extracting, creating, and converting between formats.")
 (define-public python-conda
   (package
     (name "python-conda")
-    (version "4.3.16")
+    (version "4.7.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/conda/conda/archive/"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/conda/conda/")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "1jq8hyrc5npb5sf4vw6s6by4602yj8f79vzpbwdfgpkn02nfk1dv"))))
+         "0dzplykxrlri9a5c65bc48sdjpg2i50qzjf1qf9448qkghvmnmpr"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -774,33 +775,6 @@  extracting, creating, and converting between formats.")
              (with-output-to-file "conda/.version"
                (lambda () (display ,version)))
              #t))
-         (add-before 'check 'remove-failing-tests
-           (lambda _
-             ;; These tests require internet/network access
-             (let ((network-tests '("test_cli.py"
-                                    "test_create.py"
-                                    "test_export.py"
-                                    "test_fetch.py"
-                                    "test_history.py"
-                                    "test_info.py"
-                                    "test_install.py"
-                                    "test_priority.py"
-                                    "conda_env/test_cli.py"
-                                    "conda_env/test_create.py"
-                                    "conda_env/specs/test_notebook.py"
-                                    "conda_env/utils/test_notebooks.py"
-                                    "core/test_index.py"
-                                    "core/test_repodata.py")))
-               (with-directory-excursion "tests"
-                 (for-each delete-file network-tests)
-
-                 ;; FIXME: This test creates a file, then deletes it and tests
-                 ;; that the file was deleted.  For some reason it fails when
-                 ;; building with guix, but does not when you run it in the
-                 ;; directory left when you build with the --keep-failed
-                 ;; option
-                 (delete-file "gateways/disk/test_delete.py")
-                 #t))))
          (replace 'check
            (lambda _
              (setenv "HOME" "/tmp")
@@ -813,8 +787,9 @@  extracting, creating, and converting between formats.")
        ("python-pytest" ,python-pytest)
        ("python-responses" ,python-responses)
        ("python-pyyaml" ,python-pyyaml)
-       ("python-anaconda-client" ,python-anaconda-client)))
-    (home-page "https://github.com/conda/conda")
+       ("python-anaconda-client" ,python-anaconda-client)
+       ("python-conda-package-handling" ,python-conda-package-handling)))
+    (home-page "https://conda.io")
     (synopsis "Cross-platform, OS-agnostic, system-level binary package manager")
     (description
      "Conda is a cross-platform, Python-agnostic binary package manager.  It