diff mbox series

[bug#36026,1/4] gnu: libarchive: Add zstd support.

Message ID 20190531140444.3810-1-mail@ambrevar.xyz
State Accepted
Headers show
Series Update Conda | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Pierre Neidhardt May 31, 2019, 2:04 p.m. UTC
* gnu/packages/backup.scm (libarchive)[inputs]: Include zstd.
[arguments]: Build against zstd.
---
 gnu/packages/backup.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

Comments

Ludovic Courtès June 13, 2019, 8:44 a.m. UTC | #1
Hi Pierre,

Pierre Neidhardt <mail@ambrevar.xyz> skribis:

> * gnu/packages/backup.scm (libarchive)[inputs]: Include zstd.
> [arguments]: Build against zstd.

Here you’re modifying ‘libarchive’, which has tons of dependents.

If you instead modify ‘libarchive-3.3.3’, you’ll be able to apply it
directly on master, and follow up with a patch to apply the changes on
‘libarchive’ itself in ‘core-updates’.

WDYT?

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index b15c15ad46..da128a0901 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -216,7 +216,8 @@  backups (called chunks) to allow easy burning to CD/DVD.")
        ("lzo" ,lzo)
        ("bzip2" ,bzip2)
        ("libxml2" ,libxml2)
-       ("xz" ,xz)))
+       ("xz" ,xz)
+       ("zstd" ,zstd)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -245,7 +246,8 @@  backups (called chunks) to allow easy burning to CD/DVD.")
                     (libxml2 (assoc-ref inputs "libxml2"))
                     (xz      (assoc-ref inputs "xz"))
                     (zlib    (assoc-ref inputs "zlib"))
-                    (bzip2   (assoc-ref inputs "bzip2")))
+                    (bzip2   (assoc-ref inputs "bzip2"))
+                    (zstd   (assoc-ref inputs "zstd")))
                (substitute* (string-append lib "/pkgconfig/libarchive.pc")
                  (("-lnettle")
                   (string-append "-L" nettle "/lib -lnettle"))
@@ -256,7 +258,9 @@  backups (called chunks) to allow easy burning to CD/DVD.")
                  (("-lz")
                   (string-append "-L" zlib "/lib -lz"))
                  (("-lbz2")
-                  (string-append "-L" bzip2 "/lib -lbz2")))
+                  (string-append "-L" bzip2 "/lib -lbz2"))
+                 (("-lzstd")
+                  (string-append "-L" zstd "/lib -lzstd")))
                #t))))
 
        ;; libarchive/test/test_write_format_gnutar_filenames.c needs to be