diff mbox series

[bug#35818,01/31] gnu: mate-common: Use mirror://mate/ insource URI.

Message ID 20190521085112.1985-1-hoonandon@gmail.com
State Accepted
Headers show
Series [bug#35818,01/31] gnu: mate-common: Use mirror://mate/ insource URI. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

guy fleury iteriteka May 21, 2019, 8:50 a.m. UTC
* gnu/packages/mate.scm(mate-common)[source](uri): Use "mirror://mate/"
  instead of "https://pub.mate-desktop.org/releases/" directly.
---
 gnu/packages/mate.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Tobias Geerinckx-Rice May 21, 2019, 11:26 a.m. UTC | #1
Guy,

This opened 31 bugs in our patch tracker ;-)  I've merged them all 
into this one.

You can avoid this by first sending a cover letter, and using ‘git 
send-email --in-reply-to=’.  See ‘Sending a Patch Series’ in the 
Guix manual.  Sending a single patch straight to guix-patches@ is 
fine.

Kind regards,

T G-R
guy fleury iteriteka May 22, 2019, 6:59 a.m. UTC | #2
Hi,

Thanks for the tips.
I think there is no need to send an update series!
Le 21 mai 2019 13:27, "Tobias Geerinckx-Rice" <me@tobias.gr> a écrit :

> Guy,
>
> This opened 31 bugs in our patch tracker ;-)  I've merged them all into
> this one.
>
> You can avoid this by first sending a cover letter, and using ‘git
> send-email --in-reply-to=’.  See ‘Sending a Patch Series’ in the Guix
> manual.  Sending a single patch straight to guix-patches@ is fine.
>
> Kind regards,
>
> T G-R
>
Ludovic Courtès May 24, 2019, 3:40 p.m. UTC | #3
Hello,

Tobias Geerinckx-Rice <me@tobias.gr> skribis:

> This opened 31 bugs in our patch tracker ;-)  I've merged them all
> into this one.

The patches all LGTM, but I don’t think it makes sense to split them.
It’s a case where a single patch is more appropriate IMO, because this
is all logically the same change.

Could you merge them and send the resulting patch, Guy?

Thanks!

Ludo’.
Ludovic Courtès May 27, 2019, 10:02 a.m. UTC | #4
Hi,

guy fleury iteriteka <hoonandon@gmail.com> skribis:

> From 3c76a517f763f592f49da4da15a3ee33ff25cd25 Mon Sep 17 00:00:00 2001
> From: guy fleury iteriteka <hoonandon@gmail.com>
> Date: Fri, 17 May 2019 09:15:35 +0200
> Subject: [PATCH] gnu: MATE: Use mirror://mate/ in source URIs.
>
> * gnu/packages/mate.scm(MATE packages)[source](uri): Use "mirror://mate/"
>   instead of "https://pub.mate-desktop.org/releases/" directly.

Applied, thanks!

Ludo'.
diff mbox series

Patch

diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index f234d2c..9ab0bdd 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -79,8 +79,7 @@ 
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://pub.mate-desktop.org/releases/"
-                           (version-major+minor version) "/"
+       (uri (string-append "mirror://mate/" (version-major+minor version) "/"
                            name "-" version ".tar.xz"))
        (sha256
         (base32