diff mbox series

[bug#35666,1/2] gnu: hdf5: Build a thread-safe library.

Message ID 20190510100546.17536-1-ludo@gnu.org
State Accepted
Headers show
Series Build a thread-safe hdf5 library | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Ludovic Courtès May 10, 2019, 10:05 a.m. UTC
From: Ludovic Courtès <ludovic.courtes@inria.fr>

* gnu/packages/maths.scm (hdf5)[arguments]: Pass "--enable-threadsafe
--with-pthread --enable-unsupported".
---
 gnu/packages/maths.scm | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d59028599f..2c3889ece2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -781,7 +781,17 @@  incompatible with HDF5.")
      `(;; Some of the users, notably Flann, need the C++ interface.
        #:configure-flags '("--enable-cxx"
                            "--enable-fortran"
-                           "--enable-fortran2003")
+                           "--enable-fortran2003"
+
+                           ;; Build a thread-safe library.  Unfortunately,
+                           ;; 'configure' invites you to either turn off C++,
+                           ;; Fortran, and the high-level interface (HL), or
+                           ;; to pass '--enable-unsupported'.  Debian
+                           ;; packagers chose to pass '--enable-unsupported'
+                           ;; and we follow their lead here.
+                           "--enable-threadsafe"
+                           "--with-pthread"
+                           "--enable-unsupported")
        ;; Use -fPIC to allow the R bindings to link with the static libraries
        #:make-flags (list "CFLAGS=-fPIC"
                           "CXXFLAGS=-fPIC")