@@ -2250,6 +2250,39 @@ It can read a subset of yaml and is not capable of write yaml")
"Jinja2 Extension for Dates and Times")
(license license:expat)))
+(define-public python-cookiecutter
+ (package
+ (name "python-cookiecutter")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cookiecutter" version))
+ (sha256
+ (base32
+ "0glsvaz8igi2wy1hsnhm9fkn6560vdvdixzvkq6dn20z3hpaa5hk"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-freezegun" ,python-freezegun)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-binaryornot" ,python-binaryornot)
+ ("python-click" ,python-click)
+ ("python-future" ,python-future)
+ ("python-jinja2" ,python-jinja2)
+ ("python-jinja2-time" ,python-jinja2-time)
+ ("python-poyo" ,python-poyo)
+ ("python-requests" ,python-requests)
+ ("python-whichcraft" ,python-whichcraft)))
+ (home-page
+ "https://github.com/audreyr/cookiecutter")
+ (synopsis
+ "Command-line utility to create projects from templates")
+ (description
+ "A command-line utility that creates projects from project templates,
+e.g. creating a Python package project from a Python package project template.")
+ (license license:bsd-3)))
+
(define-public python-pympler
(package
(name "python-pympler")
From: Calvin Pritchard <calvin.pritchard@asu.edu> * gnu/packages/python-xyz.scm (python-cookiecutter). New variables. --- gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++ 1 file changed, 33 insertions(+)