diff mbox series

[bug#35598,1/6] gnu: Add python-arrow

Message ID 20190506053017.7255-1-pritchard.calvin@gmail.com
State Accepted
Headers show
Series [bug#35598,1/6] gnu: Add python-arrow | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Calvin Pritchard May 6, 2019, 5:30 a.m. UTC
From: Calvin Pritchard <calvin.pritchard@asu.edu>

* gnu/packages/python-xyz.scm (python-arrow). New variables.
---
 gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b0d2b105ca..bdc6f408f0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2150,6 +2150,36 @@  JavaScript-like message boxes.  Types of dialog boxes include:
 ")
     (license license:bsd-3)))
 
+(define-public python-arrow
+  (package
+    (name "python-arrow")
+    (version "0.13.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "arrow" version))
+       (sha256
+        (base32
+         "12hbnrfwa4r9n7zpbpfvah6dh8blzb3w5f4zmhgq3dy02vqdjm3g"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-chai" ,python-chai)
+       ("python-pytz" ,python-pytz)
+       ("python-simplejson" ,python-simplejson)))
+    (propagated-inputs
+     `(("python-dateutil" ,python-dateutil)))
+    (home-page
+     "https://github.com/crsmithdev/arrow/")
+    (synopsis "Better dates and times for Python")
+    (description "Arrow is a Python library that offers a sensible,
+human-friendly approach to creating, manipulating, formatting and
+converting dates, times, and timestamps.  It implements and updates
+the datetime type, plugging gaps in functionality, and provides an
+intelligent module API that supports many common creation scenarios.
+Simply put, it helps you work with dates and times with fewer imports
+and a lot less code.")
+    (license license:asl2.0)))
+
 (define-public python-pympler
   (package
     (name "python-pympler")