diff mbox series

[bug#35193,v2,3/3] gnu: Add python-mypy

Message ID 20190430152914.13616-4-jessejohngildersleve@zohomail.eu
State Accepted
Headers show
Series Updating and fixing mypy packages | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

wednesday April 30, 2019, 3:29 p.m. UTC
* gnu/packages/python-xyz.scm (python-mypy): New public variable.
---
 gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

swedebugia June 27, 2019, 2:11 p.m. UTC | #1
On 2019-04-30 17:29, wednesday wrote:
> * gnu/packages/python-xyz.scm (python-mypy): New public variable.
> ---
>   gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
>   1 file changed, 27 insertions(+)
> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 01c065fc83..c528d2849d 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -15679,3 +15679,30 @@ standard @code{typing} module that are supported by the mypy typechecker.")
>                (propagated-inputs
>                 `(("python2-typing" ,python2-typing)
>                   ,@(package-propagated-inputs mypy))))))
> +
> +(define-public python-mypy
> +  (package
> +    (name "python-mypy")
> +    (version "0.701")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "mypy" version))
> +       (sha256
> +        (base32
> +         "05479r3gbq17r22hyhxjg49smx5q864pgx8ayy23rsdj4w6z2r2p"))))
> +    (build-system python-build-system)
> +    ;; FIXME: tests freeze at 80%

We really would like to understand why these fail and mitigate if possible.

Have you reported this upstream?

> +    (arguments '(#:tests? #f))
> +    (propagated-inputs
> +     `(("python-mypy-extensions" ,python-mypy-extensions)
> +       ("python-typed-ast" ,python-typed-ast)
> +       ("python-psutil" ,python-psutil)))
> +    (home-page "http://www.mypy-lang.org/")
> +    (synopsis "Optional static typing for Python 3 and 2 (PEP 484)")
> +    (description "Add type annotations to your Python programs, and use mypy to type check
> +them.  

This phrase is a little eh weird. Could you rephrase to something like 
"Mypy checks type annotations..." or "Mypy is a ..."?

> Mypy is essentially a Python linter on steroids, and it can catch many programming
> +errors by analyzing your program, without actually having to run it.  Mypy has a powerful
> +type system with features such as type inference, gradual typing, generics and union
> +types.")
> +    (license license:expat)))


The LICENSE file contains this: "Portions of mypy are licensed under 
different licenses.  The files under stdlib-samples are licensed under 
the PSF 2 License, reproduced below."

Could you update the patch when you get an answer from upstream?

Thanks for the patch. :)
Maxim Cournoyer April 3, 2021, 3:20 a.m. UTC | #2
Hi!

swedebugia <swedebugia@riseup.net> writes:

> On 2019-04-30 17:29, wednesday wrote:
>> * gnu/packages/python-xyz.scm (python-mypy): New public variable.
>> ---
>>   gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
>>   1 file changed, 27 insertions(+)
>> diff --git a/gnu/packages/python-xyz.scm
>> b/gnu/packages/python-xyz.scm
>> index 01c065fc83..c528d2849d 100644
>> --- a/gnu/packages/python-xyz.scm
>> +++ b/gnu/packages/python-xyz.scm
>> @@ -15679,3 +15679,30 @@ standard @code{typing} module that are supported by the mypy typechecker.")
>>                (propagated-inputs
>>                 `(("python2-typing" ,python2-typing)
>>                   ,@(package-propagated-inputs mypy))))))
>> +
>> +(define-public python-mypy
>> +  (package
>> +    (name "python-mypy")
>> +    (version "0.701")
>> +    (source
>> +     (origin
>> +       (method url-fetch)
>> +       (uri (pypi-uri "mypy" version))
>> +       (sha256
>> +        (base32
>> +         "05479r3gbq17r22hyhxjg49smx5q864pgx8ayy23rsdj4w6z2r2p"))))
>> +    (build-system python-build-system)
>> +    ;; FIXME: tests freeze at 80%
>
> We really would like to understand why these fail and mitigate if possible.
>
> Have you reported this upstream?
>
>> +    (arguments '(#:tests? #f))
>> +    (propagated-inputs
>> +     `(("python-mypy-extensions" ,python-mypy-extensions)
>> +       ("python-typed-ast" ,python-typed-ast)
>> +       ("python-psutil" ,python-psutil)))
>> +    (home-page "http://www.mypy-lang.org/")
>> +    (synopsis "Optional static typing for Python 3 and 2 (PEP 484)")
>> +    (description "Add type annotations to your Python programs, and use mypy to type check
>> +them.  
>
> This phrase is a little eh weird. Could you rephrase to something like
> "Mypy checks type annotations..." or "Mypy is a ..."?
>
>> Mypy is essentially a Python linter on steroids, and it can catch many programming
>> +errors by analyzing your program, without actually having to run it.  Mypy has a powerful
>> +type system with features such as type inference, gradual typing, generics and union
>> +types.")
>> +    (license license:expat)))
>
>
> The LICENSE file contains this: "Portions of mypy are licensed under
> different licenses.  The files under stdlib-samples are licensed under 
> the PSF 2 License, reproduced below."
>
> Could you update the patch when you get an answer from upstream?
>
> Thanks for the patch. :)

It seems python-mypy and the required dependencies were merged (last
year) from another contributor that probably had failed to notice about
them here.  Thank you nonetheless, and thanks to swedebugia for the
review!

Closing.

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 01c065fc83..c528d2849d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15679,3 +15679,30 @@  standard @code{typing} module that are supported by the mypy typechecker.")
              (propagated-inputs
               `(("python2-typing" ,python2-typing)
                 ,@(package-propagated-inputs mypy))))))
+
+(define-public python-mypy
+  (package
+    (name "python-mypy")
+    (version "0.701")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "mypy" version))
+       (sha256
+        (base32
+         "05479r3gbq17r22hyhxjg49smx5q864pgx8ayy23rsdj4w6z2r2p"))))
+    (build-system python-build-system)
+    ;; FIXME: tests freeze at 80%
+    (arguments '(#:tests? #f))
+    (propagated-inputs
+     `(("python-mypy-extensions" ,python-mypy-extensions)
+       ("python-typed-ast" ,python-typed-ast)
+       ("python-psutil" ,python-psutil)))
+    (home-page "http://www.mypy-lang.org/")
+    (synopsis "Optional static typing for Python 3 and 2 (PEP 484)")
+    (description "Add type annotations to your Python programs, and use mypy to type check
+them.  Mypy is essentially a Python linter on steroids, and it can catch many programming
+errors by analyzing your program, without actually having to run it.  Mypy has a powerful
+type system with features such as type inference, gradual typing, generics and union
+types.")
+    (license license:expat)))