diff mbox series

[bug#35193,v2,2/3] gnu: Add python-mypy-extensions

Message ID 20190430152914.13616-3-jessejohngildersleve@zohomail.eu
State Accepted
Headers show
Series Updating and fixing mypy packages | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

wednesday April 30, 2019, 3:29 p.m. UTC
* gnu/packages/python-xyz.scm (python-mypy-extensions,
  python2-mypy-extensions): New public variables.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 79271f0e41..01c065fc83 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15653,3 +15653,29 @@  under which they are run.  The typed_ast parsers produce the standard Python AST
 (plus type comments), and are both fast and correct, as they are based on the
 CPython 2.7 and 3.6 parsers.")
     (license license:asl2.0)))
+
+(define-public python-mypy-extensions
+  (package
+    (name "python-mypy-extensions")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "mypy_extensions" version))
+       (sha256
+        (base32
+         "04h8brrbbx151dfa2cvvlnxgmb5wa00mhd2z7nd20s8kyibfkq1p"))))
+    (build-system python-build-system)
+    (home-page "http://www.mypy-lang.org/")
+    (synopsis "Experimental type system extensions for programs checked with mypy")
+    (description "The @code{mypy_extensions} module defines experimental extensions to the
+standard @code{typing} module that are supported by the mypy typechecker.")
+    (license license:expat)))
+
+(define-public python2-mypy-extensions
+  (let ((mypy (package-with-python2
+                   (strip-python2-variant python-mypy-extensions))))
+    (package (inherit mypy)
+             (propagated-inputs
+              `(("python2-typing" ,python2-typing)
+                ,@(package-propagated-inputs mypy))))))