[bug#34845,29/30] gnu: qterminal: Update to 0.14.1.

Message ID 20190313153741.3683-29-meiyo@riseup.net
State Accepted
Commit d30cd1a5523428086217da98164c6473c62e7392
Headers show
Series Update LXQt to 0.14.1. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Meiyo Peng March 13, 2019, 3:37 p.m. UTC
* gnu/packages/lxqt.scm (qterminal): Update to 0.14.1.
  [arguments]: Remove #:configure-flags.
---
 gnu/packages/lxqt.scm | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index a9b1b04203..bb7558faee 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -1174,14 +1174,14 @@  processes currently in existence, much like code{top} or code{ps}.")
 (define-public qterminal
   (package
     (name "qterminal")
-    (version "0.9.0")
+    (version "0.14.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
                            version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32 "1vlza75br1ys62lgkdz26md729bfpbnasfzswp7hakmgaq1rhms1"))))
+        (base32 "0cgyaskyqginmm85d11inbi0mmxrsrnvgyx6g4l4l4iqpphfq670"))))
     (build-system cmake-build-system)
     (inputs
      `(("qtbase" ,qtbase)
@@ -1191,10 +1191,7 @@  processes currently in existence, much like code{top} or code{ps}.")
      `(("lxqt-build-tools" ,lxqt-build-tools)
        ("qttools" ,qttools)))
     (arguments
-     '(#:tests? #f                      ; no tests
-       #:configure-flags
-       ;; TODO: prefetch translations files from 'lxqt-l10n'.
-       '("-DPULL_TRANSLATIONS=NO")))
+     '(#:tests? #f))                      ; no tests
     (home-page "https://lxqt.org/")
     (synopsis "Lightweight Qt-based terminal emulator")
     (description "QTerminal is a lightweight Qt terminal emulator based on