[bug#34831,25/25] gnu: Add perl6-json.

Message ID 20190312202014.31224-25-efraim@flashner.co.il
State Accepted
Commit f0f3f70b286d634ed53b2f21f5e5633488efd4e0
Headers show
Series Add perl6 | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Efraim Flashner March 12, 2019, 8:20 p.m. UTC
* gnu/packages/perl6.scm (perl6-json): New variable.
---
 gnu/packages/perl6.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 162989b3d5..3cdfefc17d 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -285,6 +285,29 @@  code.  Any grammar in the lexical scope of the use statement will automatically
 have profiling information collected when the grammar is used.")
       (license license:artistic2.0))))
 
+(define-public perl6-json
+  (package
+    (name "perl6-json")
+    (version "1.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/moritz/json")
+               ;; The commit where 1.0 was "tagged"
+               (commit "a5ef8c179350dae44ce7fb1abb684fc62c1c2b99")))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "1kzryxkqyr129rcckd4jh0dfxdgzv71qx8dpkpm1divbfjyknlay"))))
+    (build-system rakudo-build-system)
+    (arguments '(#:with-zef? #f))
+    (home-page "https://github.com/moritz/json")
+    (synopsis "A minimal JSON (de)serializer")
+    (description "This module is a simple Perl 6 module for serializing and
+deserializing JSON.")
+    (license license:artistic2.0)))
+
 (define-public perl6-json-class
   (package
     (name "perl6-json-class")