[bug#34831,17/25] gnu: Add perl6-svg.

Message ID 20190312202014.31224-17-efraim@flashner.co.il
State Accepted
Commit 2bd04f9fc21a216f73c13e71e2f3defd1a6fdde1
Headers show
Series Add perl6 | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Efraim Flashner March 12, 2019, 8:20 p.m. UTC
* gnu/packages/perl6.scm (perl6-svg): New variable.
---
 gnu/packages/perl6.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 04e0419135..96d4a670fa 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -423,6 +423,34 @@  as per the spec and where known the places that @quot{customary} attributes are
 used.")
     (license license:artistic2.0)))
 
+(define-public perl6-svg
+  ;; Latest commit, basically unchanged since August 2015
+  (let ((commit "07190c0602aa276e5319f06aa0012452dbff3582")
+        (revision "1"))
+    (package
+      (name "perl6-svg")
+      (version (git-version "0.0.0" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/moritz/svg")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+           (base32
+            "0mkjdhg7ajksdn61n8fqhyzfd7ly9myazsvpsm02a5c2q73hdygg"))))
+      (build-system rakudo-build-system)
+      (propagated-inputs
+       `(("perl6-xml-writer" ,perl6-xml-writer)))
+      (home-page "https://github.com/moritz/svg")
+      (synopsis "Perl 6 module to generate SVG")
+      (description "This is a Perl 6 module that makes it easy to write
+@dfn{Scalable Vector Graphic files} (SVG).  Right now it is a shallow wrapper
+around @code{XML::Writer}, adding only the xmlns attributes that identifies an
+XML file as SVG.")
+      (license license:artistic2.0))))
+
 (define-public perl6-tap-harness
   (package
     (name "perl6-tap-harness")