[bug#34694] gnu: add r-styler.

Message ID 20190301080758.5548-7-anothersms@gmail.com
State Accepted
Headers show
Series [bug#34694] gnu: add r-styler. | expand

Checks

Context Check Description
cbaines/comparison success View comparison
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Nicolò Balzarotti March 1, 2019, 8:07 a.m. UTC
---
 gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Ricardo Wurmus April 19, 2019, 5:15 p.m. UTC | #1
Hi Nicolò,

> ---
>  gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
> index 6ab5ecc8da..6acd3efdba 100644
> --- a/gnu/packages/cran.scm
> +++ b/gnu/packages/cran.scm
> @@ -10777,3 +10777,33 @@ using @code{S3}.")
>      (description
>       "Wrappers on 'regexpr' and 'gregexpr' to return the match results in tidy data frames.")
>      (license license:expat)))
> +
> +(define-public r-styler […]

Thank you for the patch.  I’ve applied it with a few minor changes
(description and commit message) to the master branch with commit
107850b391.

--
Ricardo

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6ab5ecc8da..6acd3efdba 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10777,3 +10777,33 @@  using @code{S3}.")
     (description
      "Wrappers on 'regexpr' and 'gregexpr' to return the match results in tidy data frames.")
     (license license:expat)))
+
+(define-public r-styler
+  (package
+    (name "r-styler")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "styler" version))
+       (sha256
+        (base32
+         "1z24mi88snbz1avjw9phq0lzmigddvycc56s83nxzr9w9z85mh05"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-backports" ,r-backports)
+       ("r-cli" ,r-cli)
+       ("r-magrittr" ,r-magrittr)
+       ("r-purrr" ,r-purrr)
+       ("r-rematch2" ,r-rematch2)
+       ("r-rlang" ,r-rlang)
+       ("r-rprojroot" ,r-rprojroot)
+       ("r-tibble" ,r-tibble)
+       ("r-withr" ,r-withr)
+       ("r-xfun" ,r-xfun)))
+    (home-page "https://github.com/r-lib/styler")
+    (synopsis
+     "Non-Invasive Pretty Printing of R Code")
+    (description
+     "Pretty-prints R code without changing the user's formatting intent.")
+    (license license:gpl3)))