[bug#34697] gnu: add r-lintr.

Message ID 20190301080758.5548-3-anothersms@gmail.com
State Accepted
Headers show
Series [bug#34697] gnu: add r-lintr. | expand

Checks

Context Check Description
cbaines/comparison success View comparison
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Nicolò Balzarotti March 1, 2019, 8:07 a.m. UTC
---
 gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Ricardo Wurmus March 7, 2019, 7:47 p.m. UTC | #1
Hi Nicolò,

thank you for this patch.

Unfortunately, there are a couple of problems with the synopsis and the
description.  “./pre-inst-env guix lint r-lintr” will tell you about
some of the issues.  For R packages in particular please make sure that
single straight quotes as in “'RStudio'” are removed.

Please also review the Contributing section in the Guix manual for
information on what should appear in the commit message.

Could you please send an updated patch as a reply to this message?

Thanks!

--
Ricardo

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f3bd3ded8d..a9b775f67e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10726,3 +10726,34 @@  using @code{S3}.")
     (description
      "This package provides a friendly interface for the construction of regular expressions.")
     (license license:expat)))
+
+(define-public r-lintr
+  (package
+    (name "r-lintr")
+    (version "1.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "lintr" version))
+       (sha256
+        (base32
+         "0vlsgq13g2ddv3wqcxaaf7yki9yjj3j1agkh91vqlvbi90i6s8mx"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-codetools" ,r-codetools)
+       ("r-crayon" ,r-crayon)
+       ("r-digest" ,r-digest)
+       ("r-httr" ,r-httr)
+       ("r-igraph" ,r-igraph)
+       ("r-jsonlite" ,r-jsonlite)
+       ("r-knitr" ,r-knitr)
+       ("r-rex" ,r-rex)
+       ("r-rstudioapi" ,r-rstudioapi)
+       ("r-stringdist" ,r-stringdist)
+       ("r-testthat" ,r-testthat)))
+    (home-page "https://github.com/jimhester/lintr")
+    (synopsis "A 'Linter' for R Code")
+    (description
+     "Checks adherence to a given style, syntax errors and possible semantic issues.  Supports on the fly checking of R code edited with 'RStudio IDE', 'Emacs', 'Vim', 'Sublime Text' and 'Atom'.")
+    (license license:expat)))
+