[bug#34698] gnu: add org-noter.

Message ID 20190301080758.5548-2-anothersms@gmail.com
State Accepted
Headers show
Series [bug#34698] gnu: add org-noter. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Nicolò Balzarotti March 1, 2019, 8:07 a.m. UTC
---
 gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Ludovic Courtès March 15, 2019, 10:20 p.m. UTC | #1
Hello,

Nicolò Balzarotti <anothersms@gmail.com> skribis:

> ---
>  gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
>  1 file changed, 32 insertions(+)

Could you add a commit log that follows our conventions?

> +       (method url-fetch)
> +       (uri (string-append
> +             "https://stable.melpa.org/packages/org-noter-"
> +             version
> +             ".el"))

Since files on MELPA are unversioned and regularly modified in place,
could you instead use the upstream URL (presumably the GitHub repo)?

> +    (synopsis
> +     "A synchronized, Org-mode, document annotator")
         ^
‘guix lint’ probably complains about this; please remove the “A”.

> +    (description
> +     "The idea is to let you create notes that are kept in sync when you scroll through the
> +document, but that are external to it - the notes themselves live in an Org-mode file. As
> +such, this leverages the power of Org-mode (the notes may have outlines, latex fragments,
> +babel, etc...) while acting like notes that are made /in/ the document.
> +
> +Also, I must thank Sebastian for the original idea and inspiration!
> +Link to the original Interleave package:
> +https://github.com/rudolfochrist/interleave

Please change the description to describe the package contents from the
viewpoint of an outsider.  See the guidelines at
<https://www.gnu.org/software/guix/manual/en/html_node/Synopses-and-Descriptions.html>.

> +    (license license:gpl3)))

The source file header explicitly says “or any later version”, so it
should be ‘license:gpl3+’.

Could you send an updated patch?

Thank you,
Ludo’.
Brett Gilio Dec. 10, 2019, 4:55 a.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hello,
>
> Nicolò Balzarotti <anothersms@gmail.com> skribis:
>
>> ---
>>  gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
>>  1 file changed, 32 insertions(+)
>
> Could you add a commit log that follows our conventions?
>
>> +       (method url-fetch)
>> +       (uri (string-append
>> +             "https://stable.melpa.org/packages/org-noter-"
>> +             version
>> +             ".el"))
>
> Since files on MELPA are unversioned and regularly modified in place,
> could you instead use the upstream URL (presumably the GitHub repo)?
>
>> +    (synopsis
>> +     "A synchronized, Org-mode, document annotator")
>          ^
> ‘guix lint’ probably complains about this; please remove the “A”.
>
>> +    (description
>> +     "The idea is to let you create notes that are kept in sync when you scroll through the
>> +document, but that are external to it - the notes themselves live in an Org-mode file. As
>> +such, this leverages the power of Org-mode (the notes may have outlines, latex fragments,
>> +babel, etc...) while acting like notes that are made /in/ the document.
>> +
>> +Also, I must thank Sebastian for the original idea and inspiration!
>> +Link to the original Interleave package:
>> +https://github.com/rudolfochrist/interleave
>
> Please change the description to describe the package contents from the
> viewpoint of an outsider.  See the guidelines at
> <https://www.gnu.org/software/guix/manual/en/html_node/Synopses-and-Descriptions.html>.
>
>> +    (license license:gpl3)))
>
> The source file header explicitly says “or any later version”, so it
> should be ‘license:gpl3+’.
>
> Could you send an updated patch?
>
> Thank you,
> Ludo’.
>
>
>
>

Hi Ludo' and Nicolò,

Closing this as it was added in commit
576cb396eac4e8cea2b54d96382f8e77f3584e89 on 2019-06-13.

Thanks!

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 871721af3a..decab4f292 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9285,6 +9285,38 @@  timestamps and date-time format strings library for Emacs.")
        "This package creates Graphviz directed graphs from Org files.")
       (license license:gpl3+))))
 
+(define-public emacs-org-noter
+  (package
+    (name "emacs-org-noter")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://stable.melpa.org/packages/org-noter-"
+             version
+             ".el"))
+       (sha256
+        (base32
+         "1hczwva73gsyanl1ldhdvql01gy0hy2g861yzkaklyb763sx58x4"))))
+    (build-system emacs-build-system)
+    (propagated-inputs `(("emacs-org" ,emacs-org)))
+    (home-page
+     "https://github.com/weirdNox/org-noter")
+    (synopsis
+     "A synchronized, Org-mode, document annotator")
+    (description
+     "The idea is to let you create notes that are kept in sync when you scroll through the
+document, but that are external to it - the notes themselves live in an Org-mode file. As
+such, this leverages the power of Org-mode (the notes may have outlines, latex fragments,
+babel, etc...) while acting like notes that are made /in/ the document.
+
+Also, I must thank Sebastian for the original idea and inspiration!
+Link to the original Interleave package:
+https://github.com/rudolfochrist/interleave
+")
+    (license license:gpl3)))
+
 (define-public emacs-npm-mode
   (package
     (name "emacs-npm-mode")