[bug#34699] gnu: add emacs-smart-hungry-delete.

Message ID 20190301080758.5548-1-anothersms@gmail.com
State Accepted
Headers show
Series [bug#34699] gnu: add emacs-smart-hungry-delete. | expand

Checks

Context Check Description
cbaines/comparison success View comparison
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Nicolò Balzarotti March 1, 2019, 8:07 a.m. UTC
---
 gnu/packages/emacs-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

2.20.1

Comments

Arun Isaac Dec. 11, 2020, 6:28 a.m. UTC | #1
Hi,

Thanks for the patch. Sorry this has taken forever! I have now pushed to
master after changing the commit message to follow Guix conventions,
anad building from the GitHub repo instead of MELPA.

Cheers!

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index decab4f292..4f645dc695 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1231,7 +1231,39 @@  or XEmacs.")
 a set of simplified face specifications and a user-supplied color palette")
     (license license:gpl3+)))
 
+(define-public emacs-smart-hungry-delete
+  (package
+    (name "emacs-smart-hungry-delete")
+    (version "20170412.1343")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://melpa.org/packages/smart-hungry-delete-"
+             version
+             ".el"))
+       (sha256
+        (base32
+         "0x1jbzs54fcngj0ldhqsnjdn91mfywhm83dl4y9547lm1js6diy5"))))
+    (build-system emacs-build-system)
+    (home-page
+     "https://github.com/hrehfeld/emacs-smart-hungry-delete")
+    (synopsis "smart hungry deletion of whitespace")
+    (description
+     "Hungrily deletes whitespace between cursor and next word, paren or
+delimiter while honoring some rules about where space should be
+left to separate words and parentheses.
+
+Usage:
+
+with use-package:
+
+(use-package smart-hungry-delete
+  :bind ((\"<backspace>\" . smart-hungry-delete-backward-char)
+\t\t (\"C-d\" . smart-hungry-delete-forward-char)))
+")
+    (license license:gpl2+)))
+
 (define-public emacs-howm
   (package
     (name "emacs-howm")
--