[bug#34514,09/34] gnu: Add ruby-omniauth.

Message ID 20190217192314.5666-9-mail@cbaines.net
State Accepted
Headers show
Series Add more Ruby gems, some Rails related | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Christopher Baines Feb. 17, 2019, 7:22 p.m. UTC
* gnu/packags/ruby.scm (ruby-omniauth): New variable.
---
 gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Ricardo Wurmus Feb. 20, 2019, 8:34 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> * gnu/packags/ruby.scm (ruby-omniauth): New variable.

LGTM!

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0063a1f7c5..78415ecc9e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1125,6 +1125,31 @@  with a similar style to the original OAuth spec.")
     (home-page "https://github.com/oauth-xx/oauth2")
     (license license:expat)))
 
+(define-public ruby-omniauth
+  (package
+    (name "ruby-omniauth")
+    (version "1.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "omniauth" version))
+       (sha256
+        (base32
+         "1p16h1rp8by05k8gfw17xjhgwp60dk8qmj1xalv1n23kmxfsxb1x"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(;; No incldued tests
+       #:tests? #f))
+    (propagated-inputs
+     `(("ruby-hashie" ,ruby-hashie)
+       ("ruby-rack" ,ruby-rack)))
+    (synopsis "Generalized Rack framework for multiple-provider authentication")
+    (description
+     "This package provides a generalized Rack framework for multiple-provider
+authentication.")
+    (home-page "https://github.com/omniauth/omniauth")
+    (license license:expat)))
+
 (define-public ruby-open4
   (package
   (name "ruby-open4")