[bug#34514,03/34] gnu: Add ruby-terraform.

Message ID 20190217192314.5666-3-mail@cbaines.net
State Accepted
Headers show
Series Add more Ruby gems, some Rails related | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Feb. 17, 2019, 7:22 p.m. UTC
* gnu/packages/ruby.scm (ruby-terraform): New variable.
---
 gnu/packages/ruby.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Ricardo Wurmus Feb. 18, 2019, 10:43 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> * gnu/packages/ruby.scm (ruby-terraform): New variable.
[…]
> +(define-public ruby-terraform
> +  (package
> +  (name "ruby-terraform")
> +  (version "0.20.0")
> +  (source
> +    (origin
> +      (method url-fetch)
> +      (uri (rubygems-uri "ruby-terraform" version))
> +      (sha256
> +        (base32
> +          "1czpak24v570ysnk8waj1sblfm1vqh1sdwh934x4ai90ribhlbzf"))))

The indentation isn’t right here.

> +  (build-system ruby-build-system)
> +  (arguments
> +   '(;; No included tests
> +     #:tests? #f))

Could you please put this all on one line?
Christopher Baines Feb. 19, 2019, 10:43 p.m. UTC | #2
Ricardo Wurmus <rekado@elephly.net> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/ruby.scm (ruby-terraform): New variable.
> […]
>> +(define-public ruby-terraform
>> +  (package
>> +  (name "ruby-terraform")
>> +  (version "0.20.0")
>> +  (source
>> +    (origin
>> +      (method url-fetch)
>> +      (uri (rubygems-uri "ruby-terraform" version))
>> +      (sha256
>> +        (base32
>> +          "1czpak24v570ysnk8waj1sblfm1vqh1sdwh934x4ai90ribhlbzf"))))
>
> The indentation isn’t right here.

Good spot, I've fixed this now.

>> +  (build-system ruby-build-system)
>> +  (arguments
>> +   '(;; No included tests
>> +     #:tests? #f))
>
> Could you please put this all on one line?

Ok. I've taken to putting the comment inline, as this is syntactically
next to the #:tests? argument and this makes it easier to add additional
arguments, as you don't have to shuffle the comment around. I'm happy to
just put it inline though.

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e554808318..b307bc2257 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3735,6 +3735,30 @@  of terminal output.")
     ;; There is no mention of the "or later" clause.
     (license license:gpl2)))
 
+(define-public ruby-terraform
+  (package
+  (name "ruby-terraform")
+  (version "0.20.0")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (rubygems-uri "ruby-terraform" version))
+      (sha256
+        (base32
+          "1czpak24v570ysnk8waj1sblfm1vqh1sdwh934x4ai90ribhlbzf"))))
+  (build-system ruby-build-system)
+  (arguments
+   '(;; No included tests
+     #:tests? #f))
+  (propagated-inputs
+   `(("ruby-lino" ,ruby-lino)))
+  (synopsis "Ruby wrapper around the Terraform command line interface")
+  (description
+   "This package provides a Ruby wrapper around the the Terraform command line
+interface so that Terraform can be more easily invoked from Ruby code.")
+  (home-page "https://github.com/infrablocks/ruby_terraform")
+  (license license:expat)))
+
 (define-public ruby-pstree
   (package
     (name "ruby-pstree")